hplip-3.19.1.run blocks (Mint 19.1)(Traduction)

Asked by Christian Bernard on 2019-02-15

[Traduction of my previous question in french because there is no french contact]
Hello,
When I try to install hplip-3.19.1 under Linux Mint 19.1 Mate, the script always blocks with :
"
HPLIP-3.17.10 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)? :i
Starting uninstallation...
/
"
(The bar indefinitely rotates)
However I did :
- apt purge hplip and apt purge hplip-data
=> printer-driver-postscript-hp suppressed
- aptitude clean : => signal packets suppressed : ghc libbsd-dev libffi-dev libgmp-dev libgmpxx4ldbl libncurses5-dev libtinfo-dev oxygen-icon-theme.
- suppressed in root mode : /usr/share/hplip/ and /usr/share/ppd/hplip/
- suppression of ~/.hplip and /root/.hplip
- suppression of ~/hp-check.log
- apt update and apt upgrade

I dont know what to do else.
hplip-gui is not installed, only hplip-doc
Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Christian Bernard
Solved:
2019-02-18
Last query:
2019-02-18
Last reply:

Finally I resolved the problem.
I had searched by grep without any result the string "HPLIP-3.17.10" in many places (/etc, /var, ~/.config and many others).
So I had the idea to search only "3.17.10" I found Numerous results which did not concern hp or were inffensive, but also a file /etc/hp/hplip.conf that I suppressed.
And to the question relative to AppArmor, I answered "n" instead of "y".
I don't know what resolved the problem, in spite of some errors probably due to the fact that hplip-3.19.1 does not fit perfectly Mint 19.1.
But hp-toolbox seems to work.