Can't install HP Deskjet 3510 printer in LM 18

Asked by Daniel Koch on 2019-01-29

This printer was working fine in Linux Mint 18 when installed in an early 2006 iMac up till a couple days ago. That computer crashed and I'm now trying to install the same printer in a Lenovo G50 laptop running the same OS. I've run HPLIP using the latest version (3.19.1.run) as well as some earlier versions. Hplip runs as usual, but when I get to the end where I try to set up the printer, I get an error message that says there is no PPD file. I click on the folder, find the correct file (for Deskjet 3510) and hit enter, and then get a message that the installation failed because there is no PPD file.

When I tried to install an older version (I picked one from the middle of LM 18's lifespan), I had the same experience except when I got to the end where I had to choose a PPD file from the list, there were none for the Deskjet 3510 series at all.

I tried just installing it simply from the print utility built into the OS, but the printer doesn't even show up for me to click to move forward . What am I missing?

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-29
Last reply:
2019-02-14
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.