HPLIP missing packages

Asked by dln949 on 2019-01-07

Ubuntu 18.04.1, HPLIP 3.17.10.

I am attempting to install HPLIP using Synaptic. The installation reports no errors. But, when I start the HP system tray, I get this error message:

File "/usr/bin/hp-toolbox", line 269, in <module>
QApplication, ui_package = utils.import_dialog(ui_toolkit)
TypeError: 'NoneType' object is not iterable

Also, the HP icon in the tray area does nothing if I click on it - although I am able to start the HPLIP Toolbox, and that seems to work.

When I run hp-check, it tells me that the follwoing packages are missing/incompatible, and that I need to install them manually:

libnetsnmp-devel
snmp-mibs-downloader
libsnmp-dev

I do not know where to find the first two, nor how to install them manually.

Regarding libsnmp-dev: It is not installed, but via Synaptic versions 5.7.3+dfsg-1.8ubuntu3 and 5.7.3+dfsg-1.8ubuntu3.1 are available to install. However, when I try to install libsnmp-dev via Synaptic, it tells me that the following packages will be removed - but I don't want them to be removed (especially npm):

libssl1.0-dev
node-gyp
nodejs-dev
npm

So, I need some help here: How do I get the missing packages installed, get HPLIP working, get rid of the error message (above), and make the HP system tray to work, without uninstalling npm and those other packages?

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-18
Last reply:
2019-01-18

Hi Dln949,

Please try it on the latest driver from below link

https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

If you still face any issue. Please let us know.

Regards,
Santhosh

dln949 (goodstuff9) said : #2

Before I do this, I must ask this question: Do I first need to uninstall 3.17?

Can you help with this problem?

Provide an answer of your own, or ask dln949 for more information if necessary.

To post a message you must log in.