Unable to connect laser jet 100 m175nw to wifi after router change

Asked by msteinma on 2019-01-04

Hi,
I have replaced my wireless router netgear wndr3700 by a netgear orbi rbk mesh system. I'm an unable to reconnect my hp laserjet 100 color mfp m175nw to this new wifi network. Below what I have already tried using 2 different computers under ubuntu 18.04 and hplip 3.18.12 :

- reset printer to factory settings by pushing on the printers control panel simultaneously the right arrow key and the cancel key during startup
- tried to connect the printer to the wireless network using the wps method >> failure
- tried to connect the printer using the "hp-setup" command, followed by the "option wireless/802.11" with usb connection. The SSID of my wifi router is recognized, I enter the WPA password and the device manager tries to connect. I get the message "your printer has been successfully configured ...", indicating "autoip" as address mode. I am asked to disconnect the usb cable and to run hp-setup again. I do this, using the this time the option "network/ethernet/wireless", but I get systematically the message "hplip cannot detect printers in your network".

To be sure that the printer connects to the router using "autoip" I have also tried to restart the printer after disconnecting the usb cable, but no change. When I check the list of connected devices on my router I do not find my printer in the list, showing that the printer is simply not connected to my wireless network.

I have therefore also tried to attribute manually an IP address on the printers control panel, but this did not work either.

Can you help me ?
thanks
Marc

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
msteinma
Solved:
2019-01-04
Last query:
2019-01-04
Last reply:
msteinma (marc-steinmann) said : #1

Hi again,
I have finally succeeded to configure the printer by using windows 7 pro and the windows installer furnished by HP (windows was running under virtualbox on my ubuntu system). The issue thus seems to be related to hplip on ubuntu. By the way, during the past few months I had various issues with hplip (installation of scanner plugin, security key not available etc.).
Best regards
Marc