Cannot install plug-in for HP1102w printer

Asked by Len on 2019-01-02

I am trying to install my HP Laserjet 1102w printer on Ubuntu 18.04 LTS. I downloaded the latest version of HPLIP 3.18.12. Ran in through terminal. I have appeared to fix issue of missing canberra-gtk-module. I cannot install the plug in for the printer.
I run hp-setup from the terminal
Device is discovered in gui.
Device requires binary plug-in.
Ran hp-plugin. unable to receive key. continue. password. Python gobject/dbus may be not installed.
 Plug-in installation failed

Downloaded plug-in from hp opensource. Point to downloaded plug in. unable to receive key. continue. password. Python gobject/dbus may be not installed. Plug-in installation failed

I could print from 16.04.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-03
Last reply:
2019-01-18
Len (len2mea) said : #1

I solved the problem by downloading version 3.17.11 of HPLIP. The plug-in installed no problem.

you can download the latest plugin from the below path

https://developers.hp.com/hp-linux-imaging-and-printing/plugins

Can you help with this problem?

Provide an answer of your own, or ask Len for more information if necessary.

To post a message you must log in.