Lasetjet 2100 will not stop printing

Asked by plparshall on 2018-12-01

Problem printing from GhostBSD 18.10 to a wired HP LaserJet 2100,

First I tried the CUPS Manager from the GhostBSD menus and it says unable to load the PPD.

Second I webbed to CUPS and tried several variations with no luck.

Third I installed HPLIP and it appears I have an installed printer

BUT

I ordered a test print and got one sentence of crap on page 1 and then continuous blank pages which won't stop until I pull out the paper tray.

I ordered a print from Libre and continuous blank pages. I ordered a print from Pluma and continuous blank pages.

The following is the output of HP-check-t

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

hp-check[37442]: info: :
hp-check[37442]: info: :HP Linux Imaging and Printing System (ver. 3.17.11)
hp-check[37442]: info: :Dependency/Version Check Utility ver. 15.1
hp-check[37442]: info: :
hp-check[37442]: info: :Copyright (c) 2001-15 HP Development Company, LP
hp-check[37442]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[37442]: info: :This is free software, and you are welcome to distribute it
hp-check[37442]: info: :under certain conditions. See COPYING file for more details.
hp-check[37442]: info: :
hp-check[37442]: info: :Note: hp-check can be run in three modes:
hp-check[37442]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[37442]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[37442]: info: :are installed to successfully compile HPLIP.
hp-check[37442]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro
hp-check[37442]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[37442]: info: :has the proper dependencies installed to successfully run.
hp-check[37442]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode
hp-check[37442]: info: :will check both of the above cases (both compile- and run-time dependencies).
hp-check[37442]: info: :
hp-check[37442]: info: :Check types:
hp-check[37442]: info: :a. EXTERNALDEP - External Dependencies
hp-check[37442]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[37442]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[37442]: info: :d. [All are run-time checks]
hp-check[37442]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[37442]: info: :
hp-check[37442]: info: :Status Types:
hp-check[37442]: info: : OK
hp-check[37442]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[37442]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[37442]: info: :
warning: distro is not found in AUTH_TYPES
warning: 0- version is not supported. Using 0-0 versions dependencies to verify and install...
hp-check[37442]: info: :
hp-check[37442]: info: :---------------
hp-check[37442]: info: :| SYSTEM INFO |
hp-check[37442]: info: :---------------
hp-check[37442]: info: :
hp-check[37442]: info: : Kernel: FreeBSD 12.0-CURRENT FreeBSD 12.0-CURRENT #0 7ad4fada6(HEAD): Thu Aug 2 11:37:15 EDT 2018 root@hydra:/usr/obj/root/jenkins/workspace/TrueOS_-_Stable_-_Complete/TrueOS_Stable/amd64.amd64/sys/GENERIC
 Host: node32host
 Proc: FreeBSD 12.0-CURRENT FreeBSD 12.0-CURRENT #0 7ad4fada6(HEAD): Thu Aug 2 11:37:15 EDT 2018 root@hydra:/usr/obj/root/jenkins/workspace/TrueOS_-_Stable_-_Complete/TrueOS_Stable/amd64.amd64/sys/GENERIC
 Distribution: 0
hp-check[37442]: info: : Bitness: 64 bit

hp-check[37442]: info: :
hp-check[37442]: info: :-----------------------
hp-check[37442]: info: :| HPLIP CONFIGURATION |
hp-check[37442]: info: :-----------------------
hp-check[37442]: info: :
hp-check[37442]: info: :HPLIP-Version: HPLIP 3.17.11
hp-check[37442]: info: :HPLIP-Home: /usr/local/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 0 distro version
hp-check[37442]: info: :
hp-check[37442]: info: :Current contents of '/usr/local/etc/hp/hplip.conf' file:
hp-check[37442]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.11

[dirs]
home=/usr/local/share/hplip
run=/var/run
ppd=/usr/local/share/ppd/HP
ppdbase=/usr/local/share/ppd
doc=/usr/local/share/doc/hplip
html=/usr/local/share/doc/hplip
icon=/usr/local/share/applications
cupsbackend=/usr/local/libexec/cups/backend
cupsfilter=/usr/local/libexec/cups/filter
drv=/usr/local/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=no
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.11
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no

hp-check[37442]: info: :
hp-check[37442]: info: :Current contents of '/var/lib/hp/hplip.state' file:
hp-check[37442]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[37442]: info: :
hp-check[37442]: info: :Current contents of '~/.hplip/hplip.conf' file:
hp-check[37442]: info: :[commands]
scan =

[fax]
email_address =
voice_phone =

[last_used]
device_uri = "hp:/net/HP_LaserJet_2100_Series?ip=192.168.1.104"
printer_name = HP_LaserJet_2100
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1543458898
latest_available_version = 3.17.10
notify_upgrade = false
pending_upgrade_time = 0

[installation]
date_time = 11/30/2018 20:08:20
version = 3.17.11

hp-check[37442]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[37442]: info: :
hp-check[37442]: info: :--------------
hp-check[37442]: info: :| COMPILEDEP |
hp-check[37442]: info: :--------------
hp-check[37442]: info: :
hp-check[37442]: info: : error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - - MISSING 'gcc needs to be installed'
hp-check[37442]: info: : error: make make - GNU make utility to maintain groups of programs REQUIRED 3.0 - MISSING 'make needs to be installed'
hp-check[37442]: info: : error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
hp-check[37442]: info: :
hp-check[37442]: info: :------------------------
hp-check[37442]: info: :| General Dependencies |
hp-check[37442]: info: :------------------------
hp-check[37442]: info: :
hp-check[37442]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 2.7.4 OK -
hp-check[37442]: info: : python-xml Python XML libraries REQUIRED - 2.2.4 OK -
hp-check[37442]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
hp-check[37442]: info: : sane-devel SANE - Scanning library development files REQUIRED - 1.0.25 OK -
hp-check[37442]: info: : pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
hp-check[37442]: info: : error: pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 - MISSING 'pyqt4-dbus needs to be installed'
hp-check[37442]: info: : error: libpthread libpthread - POSIX threads library REQUIRED - - MISSING 'libpthread needs to be installed'
hp-check[37442]: info: : error: python-devel Python devel - Python development files REQUIRED 2.2 - INCOMPAT 'python-devel needs to be installed'
hp-check[37442]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.8 OK -
hp-check[37442]: info: : python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.8 OK -
hp-check[37442]: info: : cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -
hp-check[37442]: info: : error: reportlab Reportlab - PDF library for Python OPTIONAL 2.0 - MISSING 'reportlab needs to be installed'
hp-check[37442]: info: : error: pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING -
hp-check[37442]: info: : error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
hp-check[37442]: info: : cups-image CUPS image - CUPS image development files REQUIRED - 2.2.8 OK -
hp-check[37442]: info: : error: python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 - INCOMPAT 'python2X needs to be installed'
hp-check[37442]: info: : python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[37442]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[37442]: info: : sane SANE - Scanning library REQUIRED - 1.0.25 OK -
hp-check[37442]: info: :
hp-check[37442]: info: :----------------------
hp-check[37442]: info: :| Scan Configuration |
hp-check[37442]: info: :----------------------
hp-check[37442]: info: :
hp-check[37442]: info: : scanext Scan-SANE-Extension REQUIRED - 3.17.11 OK -
hp-check[37442]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.17.11 OK 'hpaio found in /usr/local/etc/sane.d/dll.conf'
hp-check[37442]: info: :
hp-check[37442]: info: :-------------------------
hp-check[37442]: info: :| External Dependencies |
hp-check[37442]: info: :-------------------------
hp-check[37442]: info: :
hp-check[37442]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.25 OK -
hp-check[37442]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.25 OK -
hp-check[37442]: info: : cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.8 OK 'CUPS Scheduler is running'
hp-check[37442]: info: : error: network network -wget OPTIONAL - - MISSING 'network needs to be installed'
hp-check[37442]: info: : error: policykit PolicyKit - Administrative policy framework OPTIONAL - 0.114 MISSING 'policykit needs to be installed'
hp-check[37442]: info: : error: xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 - MISSING 'xsane needs to be installed'
hp-check[37442]: info: : error: dbus DBus - Message bus system REQUIRED - 1.10.16 MISSING 'DBUS may not be installed or not running'
hp-check[37442]: info: : avahi-utils avahi-utils OPTIONAL - 0.7 OK -
hp-check[37442]: info: :
hp-check[37442]: info: :---------------------
hp-check[37442]: info: :| Python Extentions |
hp-check[37442]: info: :---------------------
hp-check[37442]: info: :
hp-check[37442]: info: : hpmudext IO-Extension REQUIRED - 3.17.11 OK -
hp-check[37442]: info: : cupsext CUPS-Extension REQUIRED - 3.17.11 OK -
hp-check[37442]: info: :
hp-check[37442]: info: :------------------------------
hp-check[37442]: info: :| DISCOVERED SCANNER DEVICES |
hp-check[37442]: info: :------------------------------
hp-check[37442]: info: :
hp-check[37442]: info: :No Scanner found.
hp-check[37442]: info: :
hp-check[37442]: info: :--------------------------
hp-check[37442]: info: :| DISCOVERED USB DEVICES |
hp-check[37442]: info: :--------------------------
hp-check[37442]: info: :
hp-check[37442]: info: :No devices found.
hp-check[37442]: info: :
hp-check[37442]: info: :---------------------------------
hp-check[37442]: info: :| INSTALLED CUPS PRINTER QUEUES |
hp-check[37442]: info: :---------------------------------
hp-check[37442]: info: :
hp-check[37442]: info: :
hp-check[37442]: info: :HP_LaserJet_2100
hp-check[37442]: info: :----------------
hp-check[37442]: info: :Type: Printer
hp-check[37442]: info: :Device URI: hp:/net/HP_LaserJet_2100_Series?ip=192.168.1.104
hp-check[37442]: info: :PPD: /usr/local/etc/cups/ppd/HP_LaserJet_2100.ppd
warning: Failed to read /usr/local/etc/cups/ppd/HP_LaserJet_2100.ppd ppd file
hp-check[37442]: info: :PPD Description:
hp-check[37442]: info: :Printer status: printer HP_LaserJet_2100 is idle. enabled since Wed Nov 28 21:36:54 2018
error: Communication status: Failed
hp-check[37442]: info: :
hp-check[37442]: info: :
hp-check[37442]: info: :--------------
hp-check[37442]: info: :| PERMISSION |
hp-check[37442]: info: :--------------
hp-check[37442]: info: :
hp-check[37442]: info: :
hp-check[37442]: info: :-----------
hp-check[37442]: info: :| SUMMARY |
hp-check[37442]: info: :-----------
hp-check[37442]: info: :
hp-check[37442]: info: :Missing Required Dependencies
hp-check[37442]: info: :-----------------------------
hp-check[37442]: info: :None
hp-check[37442]: info: :
hp-check[37442]: info: :Missing Optional Dependencies
hp-check[37442]: info: :-----------------------------
hp-check[37442]: info: :None

hp-check[37442]: info: :
hp-check[37442]: info: :Total Errors: 15
hp-check[37442]: info: :Total Warnings: 0
hp-check[37442]: info: :
hp-check[37442]: info: :
hp-check[37442]: info: :Done.

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-12-01
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask plparshall for more information if necessary.

To post a message you must log in.