Ubuntu 16.04 won't install newest HPLIP

Asked by Bruce Pastor Jr on 2018-11-09

1. Ubuntu 16.04 updated as of 20181107 on 2009 Apple MacBook Pro
2. HP PhotoSmart Premium All-in-one Printer Series - c309g
3. I don't know how to run hp-check-t because I am a groveling noob

4. I downloaded HPLIP today after my printer would no longer work. It did before the last or second to last time I updated Ubuntu. I ran the file. It took a little while. My computer is slow. The script almost completes, then tells me that it can't over-write some characters and if I would like to change from unicode 8 to another type of character. I am hazy about this because I don't have time to wait for it to run through this again after I did the next part. I ran it again and the same thing happened. I stupidly tried to have it over-write with another offered set of characters, it hung, and I forced quit the script.

5. Download HPLIP. Run HPLIP. See it not complete. Do it again. Contact you.

This website requested the following info:
1. Your Linux Distribution and version.
2. Your printer make/model.
3. If possible, run 'hp-check -t' and post the output.
4. A detailed explanation of your problem.
5. Steps to recreate the problem.

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-09
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Bruce Pastor Jr for more information if necessary.

To post a message you must log in.