7855 scanner not working

Asked by bmike1 on 2018-10-24

I have an Envy Photo 7855. The printer works great but not so much the scanner with xsane. When are you going to be supporting this scanner or else what can I do to get it to run?

1. Your Linux Distribution and version. Linux Mint 18
2. Your printer make/model. given
3. If possible, run 'hp-check -t' and post the output. see below
4. A detailed explanation of your problem. self explanatory

 hp-check -t
Saving output in log file: /home/bmike1/hp-check.log

HP Linux Imaging and Printing System (ver. 3.16.3)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

warning: linuxmint-18.3 version is not supported. Using linuxmint-17.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.15.0-36-generic #39~16.04.1-Ubuntu SMP Tue Sep 25 08:59:23 UTC 2018 GNU/Linux
 Host: MikesBeast
 Proc: 4.15.0-36-generic #39~16.04.1-Ubuntu SMP Tue Sep 25 08:59:23 UTC 2018 GNU/Linux
 Distribution: linuxmint 18.3
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.16.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro 18.3 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.16.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.16.3
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[last_used]
device_uri = hp:/net/OfficeJet_4650_series?zc=HPB05ADA63B749

[installation]
date_time = 10/23/18 22:48:17
version = 3.16.3

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------------------
| External Dependencies |
--------------------------

 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.25 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -
 error: dbus DBus - Message bus system REQUIRED - 1.10.6 MISSING 'DBUS may not be installed or not running'
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.25 OK -
 error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
 network network -wget OPTIONAL - 1.17.1 OK -

-------------------------
| General Dependencies |
-------------------------

 error: python3-devel Python devel - Python development files REQUIRED 2.2 3.5.2 MISSING 'python3-devel needs to be installed'
 libpthread libpthread - POSIX threads library REQUIRED - b'2.23' OK -
 python3-xml Python XML libraries REQUIRED - 2.1.0 OK -
 error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
 python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.5.2 OK -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
 error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
 error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 MISSING 'libcrypto needs to be installed'
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
 error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
 error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
 python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.3.0 OK -
 sane SANE - Scanning library REQUIRED - - OK -
 error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'

---------------
| COMPILEDEP |
---------------

 error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.1 OK -
 error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 5.4.0 MISSING 'gcc needs to be installed'

----------------------
| Python Extentions |
----------------------

 cupsext CUPS-Extension REQUIRED - 3.16.3 OK -
 hpmudext IO-Extension REQUIRED - 3.16.3 OK -

-----------------------
| Scan Configuration |
-----------------------

 scanext Scan-SANE-Extension REQUIRED - 3.16.3 OK -
'/etc/sane.d/dll.d/hpaio' not found.
 hpaio HPLIP-SANE-Backend REQUIRED - 3.16.3 OK 'hpaio found in /etc/sane.d/dll.conf'

-----------------------
| Other Dependencies |
-----------------------

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP-ENVY-Photo-7800-series
-------------------------
Type: Unknown
Device URI: usb://HP/ENVY%20Photo%207800%20series?serial=TH85N6V14S&interface=1
PPD: /etc/cups/ppd/HP-ENVY-Photo-7800-series.ppd
warning: Failed to read /etc/cups/ppd/HP-ENVY-Photo-7800-series.ppd ppd file
PPD Description:
Printer status: printer HP-ENVY-Photo-7800-series is idle. enabled since Mon 22 Oct 2018 03:00:05 PM EDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

--------------
| PERMISSION |
--------------

error: Unsupported model: ENVY_Photo_7800_series

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libcups2' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'openssl' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'libjpeg8-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'build-essential' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'python3-dbus.mainloop.qt' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible

Total Errors: 15
Total Warnings: 1

Done.
bmike1@MikesBeast ~ $

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-24
Last reply:
2018-10-25
bmike1 (bmike1) said : #1

it is not detecting the scanner and apparently plugins and dependencies
aren't being met.

srinivas (srinivas5) said : #2

Hi,
The hp-check logs shows many of the required dependencies are not installed. Can you install all the required dependency packages and try doing a scan job?

Can you help with this problem?

Provide an answer of your own, or ask bmike1 for more information if necessary.

To post a message you must log in.