PRINTING link missing in system>Administrator plz help...!!!!!

Asked by smneti

Hi Everybody I am pretty new to this beautiful environment of UBUNTU. I am slowly getting into this world ...meanwhile there arose a situation where in I had to Install a HP P1008 Laser jet printer.
I used the HP LINUX IMAGING AND PRINTING 3.9.2 to install my printer which installed well after i tried for a couple of times.

But the problem is I first ran the package in the ¨root terminal¨ instead of in the ¨Terminal¨ window. Which gave me an error (I dont remember the error). After that, I am not able to see the ¨Printing¨ link in System>Administrator.

Please help in getting the ¨Printing¨ thing back as I need to make my HP printer as a network printer from that link only.

Please kindly help me .........!!!!


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Aaron Albright
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :

HPLIP doesn't do anything to the System -> Admin -> Printing link. So I'm not exactly sure why it's missing.

However you can run in terminal - system-config-printer - which will run the tool that is ran when you click on the Printing link.

You should be able to add it back by:

Right click the "System" text.
Click Edit Menus
Click System
Click Administration
Make sure there is a check mark next to the "Printing" icon. If you don't have a Printing section then click:
New Item
Name: Printing
Command: system-config-printer

Should be back.

Hope this helps.


Revision history for this message
smneti (smneti) said :

Hi Aaron,
               Its nice to get a prompt reply back. Thank a million for that. I am not ale to try this
solution until tommorow.Once I try it i shall let u know if the solution worked.
Thanx once agin....!!!!


Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :

No problem. Thanks for the update.


Revision history for this message
smneti (smneti) said :

Thanks Aaron Albright, that solved my question.

Revision history for this message
smneti (smneti) said :

Hi Aaron,
              Plz ignore the above message as it is an automated message. Actually my problem is solved when I tried the very first step that u suggested. You asked me to try this first ¨system-config-printer¨ so that it runs the same program as Printing. But when i tried this command in the terminal window, it said that the printing program itself is not installed in the system and the system asked me to try this ¨sudo apt-get install system-config-printer-gnome¨ to install the printing program. And finally that solved my problem.

Thanks a lot Aaron..!!!