Scanner on Xpress m2070 stopped working after installing ubuntu 18.04

Asked by Soc Gir on 2018-10-17

I have upgraded linux ubuntu from version 16.04 to 18.04. Installed drivers for samsung xpress m2070. Printer works fine without a problem, scanner gives error:

"No scanner available. Please connect a scanner."

Thanks in advance for any help.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-17
Last reply:
2018-10-18
Soc Gir (socgir) said : #1

I have found solution in a way:

1.) sudo ln -sfr /usr/lib/sane/libsane-smfp* /usr/lib/x86_64-linux-gnu/sane

2.) Edit the file 59-smfp_samsung.rules (find it here: /etc/udev/rules.d) to include the following code/scanner number along with other Samsung model numbers already there:
ATTRS{idProduct}=="2070", ENV{libsane_matched}="yes"

Now the scanner can scan 1 document per restart of the system. When you want to scan a second page - it gives the same error, yet after restarting the OS it scans normally the first thing you want.

srinivas (srinivas5) said : #2

Hi,
Are you using the hplip driver for your printer setup? Samsung printer support in hplip is yet to be added. Can you mention the hplip driver version you tried for the printer configuration?

Can you help with this problem?

Provide an answer of your own, or ask Soc Gir for more information if necessary.

To post a message you must log in.