Problem on HP Laserjet M1132 MFP Drivers on Linux Mint 19

Asked by paulo on 2018-09-26

Hi all,

I have just installed the latest hplip drivers for my Laserjet M1132 MFP but can't print a single page. The job starts (HPLIP Device Status) and the printer is activated. But then a error message appears with the following:

"The printer's state message is: filter failed"

The printer troubleshooting window follows with:

"No system journals entries were found. This may be because you are not an administrator. To fetch journal entries please run this command"

su -c 'journalctl -u cups.service --since="None" --until="2018-09-25 21:24:50"' > troubleshoot-logs.txt

However my sudo password doesn't authenticate. An elevated prompt also doesn't help, returning the following message:

"Failed to parse timestamp: None"

Any tips on how to use this printer on Linux? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
paulo
Solved:
2018-10-01
Last query:
2018-10-01
Last reply:
2018-09-26
srinivas (srinivas5) said : #1

Hi,
Linux Mint 19 support has been added in the 3.18.9 release which has been released on 26th September. Can you download this latest version from the hplip portal (https://developers.hp.com/hp-linux-imaging-and-printing/gethplip) and let us know if you still see any issues in the installation and printer setup?

Thanks,
Srinivas Teja

paulo (ribeiro80) said : #2

Hi srinivas,

Thanks. I just added the new HPLIP 3.18.9 release. Facing exactly the same issue. Instalation is complete, the printer is active, the job is sent (lights flashing on display), but can't print a single page. Always with the same error message:

>>> Printer error <<<

Pinter troubleshooter = the printer is ready to print

and

"no system journal entries were found. This may be because you are not an administrator. To fetch journal entries please run..."

su -c 'journalctl -u cups.service --since="None" --until="2018-10-01 13:10:49"' > troubleshoot-logs.txt

whener I run this command I get the following message:
Failed to parse timestamp: None

Perhaps this specific printer is not compatible with Mint?

Thanks!

paulo (ribeiro80) said : #3

Problem solved using HPLIP 3.17.10 and:

$ hp-setup -i

At some point it was mentioned that I was not a sudoer. Then I added my login credentials and the test page went on :)