Debian missing dependencies.

Asked by Giorgos Kostopoulos on 2018-09-23

Hi! :-)

Installer complained that:
"error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing".
Then aborted.

Please take a look there:
https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=pyqt4

Can you see those packages?
Personally I can't. :-)

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-09-23
Last reply:
2018-09-24
srinivas (srinivas5) said : #1

Hi,

Did you do a OS update before running the HPLIP installer?
If not please update and retry running the HPLIP installer.
Can you share your HPLIP version and debian version details.
Also provide the hp-check output.

Thanks,
Srinivas Teja.

THANKS Srinivas for your response!

On a 2nd look, HPLIP supports Debian 9.4, while the current version is 9.5 (which I have).
As usually, HPLIP doesn't support Debian's current version, even months after it's release date. :-)

HPLIP is the latest version.

I'll install 9.4, just to be sure, I'll try again and I'll be back.

Yes, I confirm this affects the supported version.
I'm opening a bug report.
Bye!

srinivas (srinivas5) said : #4

Hi,
Debian 9.5 support is added in the 3.18.9 release planned in September last week. Please watch for the new release information in the portal - https://developers.hp.com/hp-linux-imaging-and-printing/gethplip and download the latest version for the Debian 9.5 support.

THANKS!
I'll do it.

Can you help with this problem?

Provide an answer of your own, or ask Giorgos Kostopoulos for more information if necessary.

To post a message you must log in.