need libjpeg62-dev and i am so new

Asked by Anita Jensen

ubuntu 8.10 intrepid
trying to install

everything went great up until it said:

error: A required dependency 'libjpeg (libjpeg - JPEG library)' is still missing.
error: Installation cannot continue without this dependency.
error: Please manually install this dependency and re-run this installer.

i know that it is available, I think through canonical(sp? sister watching, I'm late)

can someone tell me in detail, how to get it and install it? yes i know to use sudo and the terminal.

Thank you

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Aaron Albright
Last query:
Last reply:
Revision history for this message
Anita Jensen (entpchiquita) said :

i put it in the problem, I'm still that new. If i am asking at the wrong place, tell me where to go. you know what I mean.
Thank you for any help

Anita Jensen
<email address hidden>

Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :


Try running:

sudo apt-get install libjpeg62-dev

and then run the installer again. We've tested the installer on 8.10 recently so I'm not sure how come you are getting this error. But it should fix it.

Work ok?



Revision history for this message
Anita Jensen (entpchiquita) said :

Thank you very much, i will do that immediately! Close but no cigar.

Here is the whole thing:

anita@anita-desktop:~$ sudo apt-get install libjpeg62-dev
[sudo] password for anita:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libjpeg62-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libjpeg62-dev has no installation candidate

I'm off to get a decnt nights sleep, and will check here before i even look at my email.
Thank you very much. Anita Jensen

Revision history for this message
Anita Jensen (entpchiquita) said :

oh and just for fun.. this is just weird. I am using KDE's package for email.. suddenly when i open an email in full, the computer wants to run Thunderbird. I think i need a couse.


Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :

Try running

sudo apt-get update

and then

sudo apt-get install libjpeg62-dev

I've verified that the package is in the Ubuntu 8.10 software repos. You may need to turn on all of the repositories.


System -> Admin -> Software Sources

Then put check marks in all of the "Downloadable from Internet"

Then click close, then "reload" or run sudo apt-get update

and then again run:

sudo apt-get install libjpeg62-dev

And start the HPLIP install again and you should be good to go.

And before you do this what printer are you wanting to use anyway? It might already be supported in Ubuntu.

Try running:

sudo apt-get install hplip-gui

then to configure the printer run:

sudo hp-setup

Hope this helps.


Revision history for this message
Anita Jensen (entpchiquita) said :

Thanks Aaron Albright, that solved my question.