Suse11.1:During hplip-update "make"command failed, use of older driver for printing instead

Asked by DietrichDuveneck

Hallo,
I work with Suse 11.1 and try to run a HP Officejet j4680 All-in-one printer . The Suse distribution came with HPLIP - 2.8.7, which does not support this printer. When trying to update to version 2.8.12 I get: error "make" command failed... .
 Since I am a real beginner with Linux, I cannot handle console commands properly except with very detailed step-by-step instructions.

Now my question: For the Suse OS on my laptop I am only interested in printing functions ; which older printer driver could be used from hplip-2.8.7 to run the printing part of my Officejet j4680 or in other words, which older printer is uses similar structures??

Best regards DD

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Albright
Solved:
Last query:
Last reply:
Revision history for this message
Aaron Albright (albrigha-deactivatedaccount) said :
#1

The OfficeJet J4680 requires HPLIP version 2.8.10+. Either way you will need to upgrade to the latest for your printer to work.

Please run:

cd hplip-2.8.12

Although you will need to know from where you first ran the HPLIP installer. For example if you ran

sh hplip-2.8.12

from the Desktop

You'll then want to run:

cd ~/Desktop
cd hplip-2.8.12

then run

make

and post the last 30 or so lines of output.

Thanks.

Aaron

Revision history for this message
DietrichDuveneck (dietrichduveneck) said :
#2

Thanks for assistance: In the meantime my son was successful on another PC, solution :" Make" successful after installing the package called libgphoto2-devel.
Hope this helps also others.
Best regards DD

Another hint: If someone is in need to print urgently with HP OJ j4680 and cannot install the newest driver: driver for HP OJ j4500 works (e.g. included in HPLIP 2.8.7)

> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #59331]: Suse11.1:During hplip-update "make"command failed, use of older driver for printing instead
> Date: Mon, 2 Feb 2009 22:11:27 +0000
>
> Your question #59331 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/59331
>
> Status: Open => Needs information
>
> Aaron Albright requested for more information:
> The OfficeJet J4680 requires HPLIP version 2.8.10+. Either way you will
> need to upgrade to the latest for your printer to work.
>
> Please run:
>
> cd hplip-2.8.12
>
> Although you will need to know from where you first ran the HPLIP
> installer. For example if you ran
>
> sh hplip-2.8.12
>
> from the Desktop
>
> You'll then want to run:
>
> cd ~/Desktop
> cd hplip-2.8.12
>
> then run
>
> make
>
> and post the last 30 or so lines of output.
>
> Thanks.
>
> Aaron
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/hplip/+question/59331
>
> You received this question notification because you are a direct
> subscriber of the question.

_________________________________________________________________
http://redirect.gimas.net/?n=M0902xHMMobile
Nie wieder eine Mail verpassen mit Hotmail fürs Handy!

Revision history for this message
Best Aaron Albright (albrigha-deactivatedaccount) said :
#3

Thanks for the update.

Aaron

Revision history for this message
DietrichDuveneck (dietrichduveneck) said :
#4

Thanks Aaron Albright, that solved my question.