Nothing prints on the printer

Asked by William Colls on 2008-11-22

Environment
Ubuntu 8.10 64 Bit
HPLIP version 2.8.7 (installed from ubuntu repository)
HP LaserJet P1005 USB

When I first connected this printer, The system immediately recognized it, and I was able to configure the drivers, and print a test page. The second time I attempted to print a test page, there was no paper in the printer, and looking at the printer status messages, I saw the out of paper condition reported. However, putting paper in the printer, did not result in any output, and since that time, I have been unable to get anything to print. If I ask for the test page, I get a message saying the job was submitted, and a few seconds later, a message that the job completed. But nothing actually prints. It seems as if the first failed job is stilled queued somewhere, and the print demon is not detecting that the printer now has paper, and is ready to print. I have tried disconnecting and reconnecting the printer, re-installing it, all to no avail.

Any ideas?

TIA

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
VINODREDDY
Solved:
2008-11-26
Last query:
2008-11-26
Last reply:
2008-11-25
Best VINODREDDY (vinod-reddy) said : #1

Hi

   You need to install HPLIP as per your communication you have hplip 2.8.7, plz update to the 2.8.10 which is there on the hplip site.

onec you have downloaded the auto run file from the hplip site all you need to do is to run the file using the following command

sh hplip-2.8.10.run

once you have sucessfuly installed HPLIP 2.8.10

then you need to run hp-setup

it will request to point to the binary plugin which is there in the below url, plz downlod 2.8.10.run file from the url.

http://linuxprinting.org/download/printdriver/auxfiles/HP/plugins/

and point to the downloded file will solve your problem.

Regards

VINODREDDY

Worked a treat. Problem Very Much solved. Thank you for you generous help.