P1005 not working with hardy

Asked by Brian Cooper on 2008-11-13

My new P1005 is not working with Hardy
It works on XP
The system sees the printer but will not print.
The bug report is:
Page 1 (Choose printer):
{'cups_dest': <cups.Dest object at 0x1006530>,
 'cups_instance': None,
 'cups_queue': 'HP_LaserJet_P1005',
 'cups_queue_listed': True}
Page 2 (Check printer sanity):
{'cups_device_uri_scheme': u'hp',
 'cups_printer_dict': {'device-uri': u'hp:/usb/HP_LaserJet_P1005?serial=BC0GPLY',
                       'printer-info': u'Hewlett-Packard HP LaserJet P1005',
                       'printer-is-shared': False,
                       'printer-location': u'',
                       'printer-make-and-model': u'HP LaserJet P1005 Foomatic/foo2xqx (recommended)',
                       'printer-state': 3,
                       'printer-state-message': u'',
                       'printer-state-reasons': [u'none'],
                       'printer-type': 2134036,
                       'printer-uri-supported': u'ipp://localhost:631/printers/HP_LaserJet_P1005'},
 'is_cups_class': False}
Page 3 (Printer state reasons):
{'printer-state-message': '', 'printer-state-reasons': 'none'}
Page 4 (Print test page):
{'test_page_job_status': [], 'test_page_successful': False}
Page 5 (Printer state reasons):
{'printer-state-message': '', 'printer-state-reasons': 'none'}

Can anyone help please?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-13
Last reply:
2008-11-14
VINODREDDY (vinod-reddy) said : #1

Hi

   What version of HPLIP are you using.

vinod.K

Thanks vinod
I am on 2.8.2 in hplip
Brian

VINODREDDY wrote:
> Your question #51220 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/51220
>
> Status: Open => Needs information
>
> VINODREDDY requested for more information:
> Hi
>
> What version of HPLIP are you using.
>
> vinod.K
>
>

VINODREDDY (vinod-reddy) said : #3

Hi Brian

          You need to run hp-setup

           You need to point to the Binary Plugin which is avilable on the below url.

http://linuxprinting.org/download/printdriver/auxfiles/HP/plugins/

Let me know how it goes.

Regrds

vinod.K

VINODREDDY wrote:
> Your question #51220 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/51220
>
> Status: Open => Needs information
>
> VINODREDDY requested for more information:
> Hi Brian
>
> You need to run hp-setup
>
> You need to point to the Binary Plugin which is avilable on
> the below url.
>
>
> http://linuxprinting.org/download/printdriver/auxfiles/HP/plugins/
>
> Let me know how it goes.
>
> Regrds
>
> vinod.K
>
>
Dear vinod
Please ignore my last question as I have now followed your advice and my
problem is SOLVED
Many thanks
Brian.

Thanks Vinod!

Setting to closed.

Aaron