HP Linux Imaging and Printing

How Do I Configure HP PhotoSmart C4580 Scanner

Asked by cyauch on 2008-09-18

I have a HP PhotoSmart c4580 AIO printer, and am using Ubuntu 8.04 via KDE. I've read that at the moment, it isn't supported by HPLIP. Knowing that, I have been able to get the print portion to work by going through hp-setup, selecting the Network option and clicking the Advanced button. From there, I select all option but fax, then continue on. I enter the IP my router has assigned to the printer, and all is good. Using the PPD for the c4400 series, test pages print correctly, and all other print features / quality is outstanding.

Now, I am trying to get the scanner portion to work. When I attempt to refresh the device listing, I am asked to setup a new printer; either thru CUPS web interface, or through hp-setup. I've tried both, yet when I am done re-setting up the printer (deleting each time before i set it up again), i am continously prompted to set the printer up.

From another post i located on here about the c4440, I've installed all packaged listed:

xsane
hpoj
hpoj-xojpanel
hplip
hpijs
hplip-gui

Running XSane ends with message that nothing is found. hp-check gives the output at the end of this message. The printer is wireless, and again, printing works great. I'm rather a nood when it comes to Linux (but getting smarter everyday :-) ), but any help would be appreciated. Thanks.

P Linux Imaging and Printing System (ver. 2.8.7)
Dependency/Version Check Utility ver. 14.0

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux cyauch-desktop 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686
GNU/Linux

Distribution:
ubuntu 8.04

HPOJ running?
error: Yes, HPOJ is running. HPLIP is not compatible with HPOJ. To run HPLIP, pl
ease remove HPOJ.

Checking Python version...
OK, version 2.5.2 installed

Checking PyQt version...
OK, version 3.17 installed.

Checking SIP version...
error: SIP not installed or version not found.

Checking for CUPS...
Status: scheduler is running
Version: 1.3.7
error_log is set to level: debug

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.82.4

------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c p
arameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r param
eter (ie, hp-check -r).

Checking for dependency: cups - Common Unix Printing System...
OK, found.

Checking for dependency: cups-ddk - CUPS driver development kit...
OK, found.

Checking for dependency: cups-devel- Common Unix Printing System development fil
es...
OK, found.

Checking for dependency: dbus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter a
nd previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development
files...
OK, found.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs.
..
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline
scanning with hp-scan)...
OK, found.

Checking for dependency: ppdev - Parallel port support kernel module....
OK, found.

Checking for dependency: PyQt - Qt interface for Python...
OK, found.

Checking for dependency: python-ctypes - A foreign function library for Python..
.
OK, found.

Checking for dependency: python-dbus - Python bindings for dbus...
OK, found.

Checking for dependency: python-devel - Python development files...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality.
..
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.

----------------------
| HPLIP INSTALLATION |
----------------------

Currently installed HPLIP version...
HPLIP 2.8.7 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=2.8.7

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hpijs/HP
ppdbase=/usr/share/ppd/hpijs
doc=/usr/share/doc/hplip-2.8.7
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp/

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=yes
internal-tag=2.8.7.4
restricted-build=no

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

PDF
---
Type: Unknown
Installed in HPLIP?: No, not using the hp: or hpfax: CUPS backend.
Device URI: cups-pdf:/
PPD: /etc/cups/ppd/PDF.ppd
PPD Description: Generic PDF file generator
Printer status: printer PDF is idle. enabled since Wed 02 Jul 2008 05:22:03 AM
CDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUP
S backend to function in HPLIP.
Photosmart_C4500
----------------
Type: Printer
Installed in HPLIP?: Yes, using the hp: CUPS backend.
Device URI: hp:/net/Photosmart_C4500_series?ip=192.168.1.2
PPD: /etc/cups/ppd/Photosmart_C4500.ppd
PPD Description: HP Photosmart c4400 series Foomatic/hpijs, hpijs 2.8.7
Printer status: printer Photosmart_C4500 is idle. enabled since Wed 17 Sep 2008
 09:47:39 PM CDT
error: Unsupported model: Photosmart_C4500_series

----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.

-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

-----------
| SUMMARY |
-----------

error: 4 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
cyauch
Solved:
2008-09-18
Last query:
2008-09-18
Last reply:
cyauch (cyauch) said : #1

Update: Using a combination of links and sites to piece information together, I believe the troubles I'm having are because the HP C4580 is not supported by HPLIP....yet. From what i understand, its being worked on though. But, for those that do have this printer / scanner, i finally go the scanner to work via wireless.

Again, I used hp-setup to install the printer. When prompted, I selected Network, then next. It timed out on me. Then I selected the Manual button, and entered the IP address to the printer. I haven't been able to setup wireless on it via a Linux box (yet), so had to do it with a Windows box first. Next, I filled in the location and description, and when prompted, I selected the PPD file for the C4400 series of printers. When completed, I printed a test page from the CUPS server. To date, the device does not show up in the HP device manager, but I can print, and the quality is great.

For the scanner, I had to use some info for Ubuntu Fiesty, and is based on the install for the C4400 series. Best I can tell from reading is that the only major difference between the c4400 and c4500 series is wireless. So, again, make sure the following packages are installed:

xsane
hpoj
hpoj-xojpanel
hplip
hpijs
hplip-gui

Next, type the following in console:

sudo /etc/init.d/hpoj setup

press ENTER for parallel and USB detection. when asked for JetDirect, enter the IP of the printer, WITHOUT a port number. This is important, as XSane would time out if i entered a 1,2, or 3. Just hit ENTER when prompted for a port number. You'll get a waring about not being to read a device string, but type Y then press ENTER when asked if you really want to add this device anyway. Press ENTER again to bypass setting up another device. When done, last line should read Starting the HP Office Jet Linux Driver and display the IP address. Now, open XSane and scan away!

Sorry this is long, and if i should have posted this in another location, I apologize for that also. Linux is new to me, and thought that if there are other noobs out there using similar hardware, this might help. Thanks.

Thanks for the update. You are correct in that HPLIP does not support the C4580, however it will be supported in an upcoming release of HPLIP.

Thanks for your support!

Aaron

Kim Chee Leong (kc-leong) said : #3

Printer and scanner is working in latest version (2.8.10) hplip, installed from source.

I am posting this for anyone like me who is searching for an answer. Full support including wireless network setup is fully supported as of HPLIP 3.9.10. I just set up my C4580 wireless on Linux Mint 7 Gloria. Once HPLIP 3.9.10is downloaded from the HPLIP site and is installed, run hp-setup and choose the 802.11 wireless printer option and it will allow you to choose a wireless network to connect to and if you are using WEP/WAP/WAP2 it will allow you to enter the key phrase. I've been patiently waiting a bout a year for wireless support in Linux. Thank you HP!!!