unable to download hp plugin via setup util.

Asked by shugz204 on 2008-08-11

Hello,
mepis 7.0 user. HP laserjet p1005. I am trying to setup my new hp laserjet printer. according to the sf page, i needed hplip-2.8.7. So I followed step-by step mepis guide from sf page for install of hplip-2.8.7. Everything seemed to go well until I had to download the plug-in. I obviously have a valid network connection. Printer is detected and identified correctly, however in the next step "download the plug-in from an hp authorized server" I get the error: network connection not detected. the next screen displays local ppd files for laserjet p3005 printer. I tried this, did not work. Test page would not print.

I searched through /usr/share/ppd/hpijs/HP/ to see if there was a file for hp laserjet p1005, but was unsuccessful. Is there a place I can get the file directly rather than using this setup util? Any suggestions for how I can get your util to utilize my existing network connection?

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
shugz204
Solved:
2008-08-11
Last query:
2008-08-11
Last reply:
2008-08-11

Please run the below and post the output.

/usr/bin/wget --timeout=10 http://www.google.com

Thanks!

Aaron

shugz204 (shugz204) said : #2

/usr/bin/wget --timeout=10 http://www.google.com
--14:35:38-- http://www.google.com/
           => `index.html'
Resolving www.google.com... failed: Connection timed out.
.......

Is your internet working correctly on that system? It could also perhaps be something with the internet in your country, can you go to www.google.com and the page appears correctly?

A

shugz204 (shugz204) said : #4

yes. It is slow getting a response from my isp dns.. Takes a few seconds before it finds the page, but everything loads fine.

shugz204 (shugz204) said : #5

Aaron, is there a way to get the setup to allow for a longer timeout? It really only tries for 2 seconds before giving the error.

Actually try running:

cd hplip-2.8.7
./install.py -n

A

shugz204 (shugz204) said : #7

Aaron, I changed my DNS server and ran the setup again and it worked fine. The dns was too slow for the timeout, might be something to adjust for slower networks. Thanks for your help identifying the issue.