HPLIP Filter failed / hpcups crashing M177fw on Linux Mint 17.1

Asked by Steve on 2015-07-22

Hello,

I am trying to get a new HP M177fw laser printer working on Linux Mint 17.1 (64-bit). I've installed the HP application software and the plug-in and this all seems to be working perfectly. However, when I try to print, nothing happens and the print queue shows "Filter failed".

This is a brand new printer, and has never worked (on Linux).

Checking the log (/var/log/cups/error_log), I'm seeing this offending entry:

D [22/Jul/2015:08:54:06 +0100] [Job 43] PID 2953 (/usr/lib/cups/filter/hpcups) crashed on signal 6.

HPLIP version 3.15.7 (plug-in version the same).
Printer connected by ethernet
OS is Mint 17.1 64-bit (also tried on Mint 17 32-bit laptop - identical results)

HPLIP seems fine. I can read the toner levels etc. and there's no errors.
hp-doctor shows no errors.
Scanning works fine through SANE.
If I enter the printer's IP in Firefox, I can run a test page from there, which works ok (but his bypasses CUPS completely).
I've tried printing from different applications, but they all fail in the same way.
Printer works fine on windows.

I've re-installed HPLIP & the plug-in several times, I've removed and re-installed CUPS, I've tried different (similar) printer drivers from the list.

I've added the printer through HPLIP, through CUPS on Firefox, and through System Settings/Printers. No matter how I do it, the results are the same.

The thing is, the installation always seems straightforward and error-free. It's just that I can't print anything at the end of it!

Is the "hpcups" filter broken? Can I configure it somehow? Can I get a replacement one...?!

Any suggestions appreciated - I've run out of ideas!

Many thanks,

Steve.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Steve
Solved:
2015-07-27
Last query:
2015-07-27
Last reply:
Steve (tteve) said : #1

With no help from HP - the staff on their support line were rude and unhelpful - I've found a solution:

I've just installed the previous version of HPLIP (3.15.6), and this seems to cure the problem.

jens7677 (jpeters7677) said : #2

I'm seeing the same behaviour on Fedora 22 with hplip 3.15.7 with the same printer model. Also on fedora the printer worked fine before hplip got updated.

Running Cupsd in debug mode gives the following clue: Assertion `currSourceWidth+(2*leftMargin)<=currMediaWidth' failed.

Aug 01 07:40:22 linux-k92s.lan audit[4084]: <audit-1701> auid=4294967295 uid=4 gid=7 ses=4294967295 pid=4084 comm="hpcups" exe="/usr/lib/cups/filter/hpcups" sig=6
Aug 01 07:40:22 linux-k92s.lan cupsd[1113]: [Job 39] HP_Color_LaserJet_Pro_MFP_M177fw: genPCLm.cpp:194: ubyte* shiftStripByLeftMargin(ubyte*, sint32, sint32, sint32, sint32, sint32, colorSpaceDisposition): Assertion `currSourceWidth+(2*leftMargin)<=currMediaWidth' failed.
Aug 01 07:40:22 linux-k92s.lan cupsd[1113]: Discarding unused job-progress event...
Aug 01 07:40:22 linux-k92s.lan cupsd[1113]: [19B blob data]
Aug 01 07:40:22 linux-k92s.lan cupsd[1113]: [Job 39] prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1STATE: +connecting-to-device
Aug 01 07:40:22 linux-k92s.lan hpcups[4084]: prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1

Please reopen this bug report. Downgrading is just temporarily solution. This one should be resolved properly. Furthermore, please let me know if I can assist any further.

Regards,
Jens

goutam (goutamkk) said : #3

This is an issue with hplip 3.15.7 drivers. I have provided the patch for the same in the bug report
https://bugs.launchpad.net/hplip/+bug/1476920.
This issue will be resolved in our next version of hplip.

If you wish to go back to hplip-3.15.6. You can download the drivers from
http://sourceforge.net/projects/hplip/files/hplip/3.15.6/hplip-3.15.6.run/download

Sorry for the inconvenience.

Thanks,
Goutam

jens7677 (jpeters7677) said : #4

Hello Goutam,

Thanks for the info and nice to read that. Looking forward to the next version and thanks again for your work!

Regards,
Jens

Johannes Kropf (johannes-j) said : #5

Hi,

thanks, I had the same issues with the HP LaserJet MFP M127fw and downgrading the driver to 3.15.6 solved it!

Regards,
Johannes