hplip-3.14.10.run failing to install dependencies.

Asked by Eric on 2014-11-16

I'm trying to install the drivers for an HP Photosmart c5280 on a system running Debian 6.0.10
It fails when it tries to install the required dependencies... specifically starting with...

Running 'su -c "apt-get install --force-yes -y python-dev"'

and continues to fail through all next dependencies.

When I try to install python-dev manually, I'm met with this error...

$ sudo apt-get install --force-yes -y python-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  python
E: Package 'python-dev' has no installation candidate

Interestingly enough, on a whim I tried running

$sudo apt-get python

where I'm met with...

sudo apt-get install python
Reading package lists... Done
Building dependency tree
Reading state information... Done
python is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38+deb7u6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

^ This may or may not have anything to do with the problem, but it could prove to be a useful clue...

My sources.list is as follows...

deb http://archive.debian.org/debian oldstable main contrib non-free
deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

My install log is as follows...

hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mHP Linux Imaging and Printing System (ver. 3.14.10)[0m
hplip-install[25985]: info: :[01mHPLIP Installer ver. 5.1[0m
hplip-install[25985]: info: :
hplip-install[25985]: info: :Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
hplip-install[25985]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hplip-install[25985]: info: :This is free software, and you are welcome to distribute it
hplip-install[25985]: info: :under certain conditions. See COPYING file for more details.
hplip-install[25985]: info: :
hplip-install[25985]: info: :Installer log saved in: [01mhplip-install_Sun-16-Nov-2014_19:15:24.log[0m
hplip-install[25985]: info: :
hplip-install[25985]: info: :
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mINSTALLATION MODE[0m
hplip-install[25985]: info: :[01m-----------------[0m
hplip-install[25985]: info: :Automatic mode will install the full HPLIP solution with the most common options.
hplip-install[25985]: info: :Custom mode allows you to choose installation options to fit specific requirements.
hplip-install[25985]: info: :
Initializing. Please wait...
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mINTRODUCTION[0m
hplip-install[25985]: info: :[01m------------[0m
hplip-install[25985]: info: :This installer will install HPLIP version 3.14.10 on your computer.
hplip-install[25985]: info: :Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mDISTRO/OS CONFIRMATION[0m
hplip-install[25985]: info: :[01m----------------------[0m
hplip-install[25985]: info: :Distro appears to be Debian 6.0.

hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mENTER ROOT/SUPERUSER PASSWORD[0m
hplip-install[25985]: info: :[01m-----------------------------[0m
:

:
:
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mINSTALLATION NOTES[0m
hplip-install[25985]: info: :[01m------------------[0m
hplip-install[25985]: info: :NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mRUNNING PRE-INSTALL COMMANDS[0m
hplip-install[25985]: info: :[01m----------------------------[0m
hplip-install[25985]: info: :OK
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
hplip-install[25985]: info: :[01m-------------------------------------[0m
warning: There are 6 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mINSTALL MISSING OPTIONAL DEPENDENCIES[0m
hplip-install[25985]: info: :[01m-------------------------------------[0m
warning: There are 14 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'network': libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency for option 'network': libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing OPTIONAL dependency for option 'network': avahi-utils (avahi-utils)
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
warning: Missing OPTIONAL dependency for option 'gui_qt4': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing REQUIRED dependency for option 'fax': python-dbus (Python DBus - Python bindings for DBus)
warning: Missing OPTIONAL dependency for option 'fax': reportlab (Reportlab - PDF library for Python)
warning: Missing REQUIRED dependency for option 'fax': dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency for option 'scan': sane-devel (SANE - Scanning library development files)
warning: Missing OPTIONAL dependency for option 'scan': pil (PIL - Python Imaging Library (required for commandline scanning with hp-scan))
warning: Missing OPTIONAL dependency for option 'scan': scanimage (scanimage - Shell scanning program)
warning: Missing OPTIONAL dependency for option 'scan': xsane (xsane - Graphical scanner frontend for SANE)
warning: Missing REQUIRED dependency for option 'scan': sane (SANE - Scanning library)
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mCHECKING FOR NETWORK CONNECTION[0m
hplip-install[25985]: info: :[01m-------------------------------[0m
hplip-install[25985]: info: :Network connection present.
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mRUNNING PRE-PACKAGE COMMANDS[0m
hplip-install[25985]: info: :[01m----------------------------[0m
hplip-install[25985]: info: :su -c "dpkg --configure -a" (Pre-depend step 1)
warning: An error occurred running 'su -c "apt-get install -f"'
hplip-install[25985]: info: :su -c "apt-get install -f" (Pre-depend step 2)
warning: An error occurred running 'su -c "apt-get update"'
hplip-install[25985]: info: :su -c "apt-get update" (Pre-depend step 3)
hplip-install[25985]: info: :OK
hplip-install[25985]: info: :
hplip-install[25985]: info: :
hplip-install[25985]: info: :[01mDEPENDENCY AND CONFLICT RESOLUTION[0m
hplip-install[25985]: info: :[01m----------------------------------[0m
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y python-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y python-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y python-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y python-dev"'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
warning: Some HPLIP functionality might not function due to missing package(s).
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
hplip-install[25985]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
error: Package install command failed with error code 100

I'm happy to give more info as necessary. It'd be nice to figure this out...

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Eric
Solved:
2014-11-17
Last query:
2014-11-17
Last reply:
Eric (eric-a) said : #1

I figured out what my issue was. My "libc6" had been upgraded too far for my version of linux. The solution was to run

$sudo aptitude install -f

Then accept the solution that was downgrading libc6.

All is now right in the world.