LaserJet 3030: Regressions / Confusion wrought by Ubuntu 13.10

Asked by floid on 2013-11-05

Help me decide what I should blame here:

LaserJet 3030 - up through Ubuntu 13.04, it's been a pleasant surprise that at least printing and scanning have continued to Just Work with hplip (give or take some minor annoyances with subtle page scaling making LibreOffice label templates useless).

My move to 13.04 was effectively a 'fresh install' so that would seem to confirm things Just Worked when selecting the hplip/hpcups driver there...

Upgrading Ubuntu from 13.04 to 13.10 decided to wipe out most of the queues since I had multiple queues aimed at the same device.* (Thanks, Ubuntu.)

In 13.10 with hplip 3.13.9-1 and printer-driver-hpcups 3.13.9-1, using the "HP LaserJet 3030 pcl3, hpcups 3.13.9" definition offered by the GUI:

- Print quality has regressed to something horribly dithered and low-resolution, particularly for graphics data like PDF scans;

- Generally the first page of a multi-page PDF will print and then everything will 'give up'.

Trying to use the alternative of the 'recommended' Postscript configuration hits a showstopping known bug printing envelopes from LibreOffice and printing a PDF can take upwards of 5+ minutes per page on a new AMD Trinity-type desktop.

Is anything about this "known" before I lose more lifetime debugging printing issues?

*For whatever reason, it decided to preserve only the raw queue I keep set aside for Windows clients, then nag me at boot about the PPD for that queue being invalid. I believe I finally solved that in the GUI by 'giving' it a driver and then turning it back to a "Local Raw Printer". Previously I had the hplip queue set as default for Linux printing with another set up for the rare times I'd want to try throwing Postscript directly at the printer.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
floid
Solved:
2013-11-25
Last query:
2013-11-25
Last reply:
2013-11-21
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

floid (jkanowitz) said : #2

Deleted queues were actually a hplip bug, see #1253432.

Still puzzled about the regression to low-fidelity ordered-dither output when the "hpcups" driver is selected, if that sounds familiar to anyone.

floid (jkanowitz) said : #3

"Oh."

I found out I had a backup of /etc from when things worked, and...

The previously working configuration was apparently configured by hplip but used foomatic-rip.
Relevant lines to identify where that came from:
*FileVersion: "hpijs 3.9.8"
*PCFileName: "hp-laserjet_3030-hpijs-pcl3.ppd"
*Product: "(HP LaserJet 3030 All-in-one Printer)"
*ModelName: "HP LaserJet 3030 hpijs"
*ShortNickName: "HP LaserJet 3030 hpijs"
*NickName: "HP LaserJet 3030 hpijs pcl3, 3.9.8"

Choosing the "Foomatic/Postscript" driver for the "LaserJet 3020 3030" produced equivalent output on the test page, so I'm going to try living with that for a while [for productivity reasons].

Creating queues in the HP Device Manager for hplip 3.13.9-1 (find "HP Toolbox" in the dash, use green "+" icon in UI) now uses hpcups.

This appears to be what someone previously complained of at https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1036236 . And apparently "printer-driver-hpijs" remains available as a package, but isn't installed - possibly was autoremoved during an upgrade.

Tangentially, I'm not sure who to blame for Ubuntu including both "LaserJet 3020 3030 (recommended)" and individual "LaserJet 3030" (and "LaserJet 3020") hardware in its driver menu.

floid (jkanowitz) said : #4

...and Ubuntu's "Foomatic/Postscript" produces nice output for the test page but LibreOffice jobs just spit an "invalidaccess" error out the printer.

Reinstalling "printer-driver-hpijs" and selecting its PPD ("... hpijs" option in GUI), then turning the default resolution back up to "High" (600dpi) quality now produces good output and probably recovers how things were. Whew.

(The default of 300dpi looks more jagged and atrocious than I remember 300dpi looking - like there's a font hinting bug somewhere - but apparently I've never been using it.)