HPLIP Status Service No system tray detected Unable to start, exiting

Asked by Sean Holland on 2013-06-04

I have been having extensive problems in getting my printer to fuction while running Linux (Zorin OS 6.3) (but I can scan). After inintally installing HPLIP, I was able to print fine unti l recently started receiving this HPLIP Status Service error message :

No system tray detected on this system. Unable to start, exiting.

When I open up the Startup Application Preferences, the HP System Tray Service is selected- it is present on my computer. Based on the searches I have done, I have learned that the System Tray needs to wait for a longer period of time so the system can regonize it. Rinzwind's comment indicates that a line can be edited to chage this here:

http://askubuntu.com/questions/101828/no-system-tray-detected-on-this-system

However, I have no idea how to access this line of code either in the terminal or elsewhere. In fact I am very new to Linux, and have minimal experience using the termial. Also, according the following bug report/discussion, the problems is solved. Comments on that page indicate the same solution as the former, but again, I do not know how to impliment that change. There are other comments suggesting other solutions, but I don't know how to impliment those either.

https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/335662

I am greatly appreciative of any assistance leading to a solution. I have spent several hours on this problem, and I need to have it fixed soon.

Thank you,

Sean Holland

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2013-06-04
Last reply:
2015-01-08

Hi,

Which version of HPLIP is being used?

Can you post us hp-check command output here.
$ hp-check

You can change the delay as follows:-
1) if "/usr/share/hplip/ui/systemtray.py" file exists, then add following in root mode.
--> search for "managerWin = self.locateTray(dpy)" below that you will find
          if x> 30: break
          time.sleep(2.0)
--> change the value from 30 to required one.

(or)

2) if "/usr/share/hplip/ui4/systemtray.py" file exists, then add following in root mode
--> search for "if QSystemTrayIcon.isSystemTrayAvailable():", above that you will find
      while i < 60:
or
     while i < 10:

--> change this value to more.

Thanks & Regards,
Amarnath

Arjo (arjospam) said : #2

I tried the suggested solution. It did not help. I have found the line with the ui4 directory in it. I changed the mentioned line:
it was:
    i = 0
    while i < 60:
        if QSystemTrayIcon.isSystemTrayAvailable():
            break
        time.sleep(1.0)
        i += 1

i changed it to:
    i = 0
    while i < 90:
        if QSystemTrayIcon.isSystemTrayAvailable():
            break
        time.sleep(1.0)
        i += 1

goutam (goutamkk) said : #3

Hi Arjo,

Can you give us some details on the issue that you are facing.
Provide us the output of 'hp-check' command.
Also provide us the details on the operating system that you are using.
Can you post us the output of the command 'hp-systray -x -g'

Rgds,
Goutam

Arjo (arjospam) said : #4

Hi, I cannot provide the details right now. However, I was able to fix it with the help of this ubuntu.stackexchange question:

3

down vote

In your start up programs there is a line regarding starting hplip. Change ...
sh -c "sleep 15; exec hp-systray"

to
sh -c "sleep 45; exec hp-systray"

and the problem is gone.

hplip is expecting a system tray and that got removed (and was changed into notification area). All this does is postpone startup of hp-systray so if your system is slow to respond this notice might come back and bite you again.

Found it here on Bugzilla (has a fix released on 2011.11.25 (...)). Besides the bug I found the following sources: Linuxquestions, Ubuntuforums

http://askubuntu.com/questions/101828/no-system-tray-detected-on-this-system
(also posted by Sean Holland, who posted the question).

Only thing Sean needs is information on how he can edit the starter for the system tray.

I believe, in ubuntu, it would be something like: open the applications menu. Go to 'settings' or whatever it is called. Search for something which is called startup applications. Search for hp systray in the list and press 'edit'. then copy and paste the suggested code in the 'command' field.

Restart, and everything should be working fine (at least at my Essential OS Luna distro it is).

Can you help with this problem?

Provide an answer of your own, or ask Sean Holland for more information if necessary.

To post a message you must log in.