HP P1505n driver needed but for debian squeeze 6.0.7

Asked by George Langford on 2013-04-04

Here's the place where I got the driver file:
http://hplipopensource.com/hplip-web/downloads.html

However, the installation log says that debian 6.0.7 isn't supported, and I haven't
managed to find a driver from the list of five or six that doesn't call this printer a
"two sided color printer." It's a one sided greyscale printer. It worked fine while it
was running under debian lenny (5.0.x). I don't have any CD's listed in the apt-
sources.list file.

When or where can I expect to find a workable driver for this printer under debian 6.0.7 ?

Thanks,
George Langford
<email address hidden>

Installation log:

hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mHP Linux Imaging and Printing System (ver. 3.13.3)[0m
hplip-install[3215]: info: :[01mHPLIP Installer ver. 5.1[0m
hplip-install[3215]: info: :
hplip-install[3215]: info: :Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
hplip-install[3215]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hplip-install[3215]: info: :This is free software, and you are welcome to distribute it
hplip-install[3215]: info: :under certain conditions. See COPYING file for more details.
hplip-install[3215]: info: :
hplip-install[3215]: info: :Installer log saved in: [01mhplip-install_Thu-04-Apr-2013_12:42:36.log[0m
hplip-install[3215]: info: :
hplip-install[3215]: info: :
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-6.0.7 version is not supported, so all dependencies may not be installed. However trying to install using debian-6.0.6 version packages.
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mINSTALLATION MODE[0m
hplip-install[3215]: info: :[01m-----------------[0m
hplip-install[3215]: info: :Automatic mode will install the full HPLIP solution with the most common options.
hplip-install[3215]: info: :Custom mode allows you to choose installation options to fit specific requirements.
hplip-install[3215]: info: :
Initializing. Please wait...
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mINTRODUCTION[0m
hplip-install[3215]: info: :[01m------------[0m
hplip-install[3215]: info: :This installer will install HPLIP version 3.13.3 on your computer.
hplip-install[3215]: info: :Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mDISTRO/OS CONFIRMATION[0m
hplip-install[3215]: info: :[01m----------------------[0m
hplip-install[3215]: info: :Distro appears to be Debian 6.0.7.

hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mENTER ROOT/SUPERUSER PASSWORD[0m
hplip-install[3215]: info: :[01m-----------------------------[0m
:

hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mINSTALLATION NOTES[0m
hplip-install[3215]: info: :[01m------------------[0m
hplip-install[3215]: info: :NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mRUNNING PRE-INSTALL COMMANDS[0m
hplip-install[3215]: info: :[01m----------------------------[0m
hplip-install[3215]: info: :OK
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mINSTALL MISSING REQUIRED DEPENDENCIES[0m
hplip-install[3215]: info: :[01m-------------------------------------[0m
warning: There are 5 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mINSTALL MISSING OPTIONAL DEPENDENCIES[0m
hplip-install[3215]: info: :[01m-------------------------------------[0m
warning: There are 5 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'network': libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
warning: Missing REQUIRED dependency for option 'fax': dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency for option 'scan': sane-devel (SANE - Scanning library development files)
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mCHECKING FOR NETWORK CONNECTION[0m
hplip-install[3215]: info: :[01m-------------------------------[0m
hplip-install[3215]: info: :Network connection present.
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mRUNNING PRE-PACKAGE COMMANDS[0m
hplip-install[3215]: info: :[01m----------------------------[0m
hplip-install[3215]: info: :su -c "dpkg --configure -a" (Pre-depend step 1)
hplip-install[3215]: info: :su -c "apt-get install -f" (Pre-depend step 2)
hplip-install[3215]: info: :su -c "apt-get update" (Pre-depend step 3)
hplip-install[3215]: info: :su -c "apt-get install --yes cupsys-bsd" (Pre-depend step 4)
hplip-install[3215]: info: :OK
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mDEPENDENCY AND CONFLICT RESOLUTION[0m
hplip-install[3215]: info: :[01m----------------------------------[0m
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libcups2-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y cups-bsd"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y cups-client"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libusb-1.0.0-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libtool"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libcupsimage2"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libcupsimage2-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libjpeg62-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libsnmp-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y python-qt4-dbus"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y python-qt4"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libdbus-1-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :Running 'su -c "apt-get install --force-yes -y libsane-dev"'
Please wait, this may take several minutes...
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mRUNNING POST-PACKAGE COMMANDS[0m
hplip-install[3215]: info: :[01m-----------------------------[0m
hplip-install[3215]: info: :OK
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mRE-CHECKING DEPENDENCIES[0m
hplip-install[3215]: info: :[01m------------------------[0m
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mPRE-BUILD COMMANDS[0m
hplip-install[3215]: info: :[01m------------------[0m
hplip-install[3215]: info: :OK
hplip-install[3215]: info: :
hplip-install[3215]: info: :
hplip-install[3215]: info: :[01mBUILD AND INSTALL[0m
hplip-install[3215]: info: :[01m-----------------[0m
hplip-install[3215]: info: :Running './configure --with-hpppddir=/usr/share/ppd/HP --prefix=/usr --enable-qt4 --disable-libusb01_build --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disa

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
George Langford
Solved:
2013-04-04
Last query:
2013-04-04
Last reply:
George Langford (amenex) said : #1

Found the answer here: http://wiki.debian.org/SystemPrinting#HP.

I just ran hp-setup from the command line in terminal. First I cd'ed to the location to which I had downloaded the HPLIP installer and from which I had run the installer as described in my original question. Hp-setup had trouble finding my P1505n printer until I used the Advanced Options and entered the static IP address of the printer. After that, I just followed the steps in the above wiki.debian.org link. Once I restarted cups and rebooted the computer (running debian squeeze, version 6.0.7) I could print a very pretty test page and print from the IceApe browser. Seems like CUPS is working OK now.

Seems to me that this procedure is described elewhere, but what I read before did not make it clear that both steps (first the download & installation of the original question and then running hp-setup from among the files laid down by that installer. The installer itself did not make this clear.

Thanks,
George Langford