Cannot set scan resolution on a Photosmart C6380

Asked by Fabio I. Zyserman on 2012-09-15

Hi all,
I have a working Photosmart C6380 wirelessly connected to a box with a Fedora 17 distro.

I am able to print and scan, but I am unable to set the scan resolution. When using xsane, the
resolution button appears empty. When using hp-scan, it states:

hp-scan -mcolor -r600 -opru.jpg

HP Linux Imaging and Printing System (ver. 3.12.4)
Scan Utility ver. 2.2

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hpaio:/net/Photosmart_C6300_series?ip=

warning: Output file '/home/zyserman/Descargas/pru.jpg' exists. File will be overwritten.
Using device hpaio:/net/Photosmart_C6300_series?ip=
Opening connection to device...
warning: The scan current parameters will cause very large files to be created.
warning: This can cause the scan to take a long time to complete and may cause your system to slow down.
warning: Approx. number of bytes to read from scanner: 102.3 MB (107314195)

Resolution: 600dpi
Mode: color
Compression: JPEG
Scan area (mm):
  Top left (x,y): (0.000000mm, 0.000000mm)
  Bottom right (x,y): (215.899994mm, 296.925995mm)
  Width: 215.899994mm
  Height: 296.925995mm
Destination(s): file
Output file: /home/zyserman/Descargas/pru.jpg
error: Unable to set option resolution to value 600 <----------- ERROR!
error: Unable to set option source to value Flatbed <----------- ERROR!

Warming up...

Expecting to read 1.6 MB from scanner.
Reading data: [**************************************************] 100% 1.6 MB
Read 1.6 MB from scanner.
Closing device.

Outputting to destination 'file':
Saving to file /home/zyserman/Descargas/pru.jpg


The image is scanned, but to a resolution I don`t know. I have tried with different resolutions, and I keep receiving
this error message. I have also tested newer versions of hplip, and the problem remains.

Any hint?

Best regards,

Fabio Zyserman

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Fabio I. Zyserman
Last query:
Last reply:
Fabio I. Zyserman (zyserman) said : #1

I have solved the problem by myself.

I have installed an older version of hplip, 3.10.6

Everything works well.

But the problem remains with new versions, so something has been changed for bad.

gbe54 (gbe54) said : #2

Same problem with Photosmart b210a

The scan works properly under fedora 16 but resolution is ignored on fedora 17.

gbe54 (gbe54) said : #3

The problem is not solved. Using an older version is a workarround.

I hope, this device supports only flatbed scan.

Please open /usr/share/hplip/data/models/modes.dat file in root mode and search '[photosmart_c6300_series]'. In that section, make scan-src=1 and save the file.

Now run 'hp-scan' again. Are you getting the same error?

Mjules (mjulien-m) said : #5


changing scan-src from 2 to 1 in /usr/share/hplip/data/models/models.dat seems to solve the problem for me (C6380). I can set the resolution and scan as usual.

Thank you.

Grant Traynor (grant-traynor) said : #6

Yes, that's fixed it for me also. Thanks very much for resolving this so quickly ... well done!