hplip-gui not available on Mint-12 (Cinnamon)

Asked by David Vincent-Jones

My hp photosmart-pro b8850 appears to be correctly installed and functional on mint-12 but I cannot get access to the GUI to check ink levels and other settings.

I have tried, directly from synaptic, to install the GUI but now understand that it now runs under KDE.

When I try to install the downloaded hpsetup it appears that there are massive deficiencies.

I have relied on this hp device and the gui for some years ... maybe you can advise me how to solve this dilemma.

Thank you;


Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
David Vincent-Jones
Last query:
Last reply:
Revision history for this message
David Vincent-Jones (davidvj) said :

I have no idea what made a difference but but finally the gui is now installed and an icon is onto my menu.

During the attemp to solve the problem by installing hplip through the terminal it appears that several items were missing and it was indicated that this was a KDE application ... very strange since I have used the hplip gui for many years. Anyway it now appears to be in place.