HP Linux Imaging and Printing

A3 printout clipped to A4 dimensions

Asked by William Noad on 2012-02-13

I'm trying to print to an HP Deskjet 1220C. I have a .PS file that prints to an A3 page that I have used for several years.
After upgrading my system to Ubuntu 11.10 (amd64), running HPLIP 3.11.7, I am unable to print correctly to an A3 page.
The output of both my own .PS file and the HPLIP Toolbox is clipped on the page to a portrait A4 size.
As far as I can see, the ppd files in /etc/cups/ppd are all configured correctly for this printer.
The default page size, media dimensions, etc are all set to A3.
I have a lot of A3 size printing to do at the moment and this is a very annoying problem.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Srikanth
Solved:
2012-02-17
Last query:
2012-02-17
Last reply:
2012-02-13
Best Srikanth (srikanth-lokare) said : #1

Hi William,

Can you also please try upgrading the HPLIP to 3.12.2? The Latest HPLIP release can be found at http://hplipopensource.com/hplip-web/gethplip.html. Installation instructions can also be found in the same page. After installation delete all the existing print queues using following command.

$system-config-printer.

Then re-configure the queue using "hp-setup" from the terminal. Let us know if the problem still persists.

Thanks and Regards,
Srikanth Lokare

William Noad (william-noad) said : #2

Thanks Srikanth, that solved my question.