HP Linux Imaging and Printing

HP device manager requires an additional driver plug-in...

Asked by gaetano iaquinta on 2011-09-16

I try to install an hp lj 1018 on asus eeepc - ubuntu 10.04 lts (easy peasy)

the installation appears to go ok

when i run hp-setup
HP device manager in the step 1/2 says:
 "An additional driver plug-in is required to operate with this printer...."

then it is possible to choose
1) download and install the plug-in from an HP authorized server(recommended)
2) select a local copy... browse...

i choose 1 because i have not a local driver copy

then i get the following message

HP Device Manager - HP plugin installer
ERROR: Plug-in file does not match its digital signature.
File may have been corrupted or altered.
Error code: 2

this is the details log of console:
---------------------------------------------------------------------------------
HP Linux Imaging and Printing System (ver. 3.11.7)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/Checking for network connection...
Downloading configuration file from: http://hplip.sf.net/plugin.conf
Checking for network connection...
Downloading plug-in from: http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.11.7-plugin.run
Receiving digital keys: /usr/bin/gpg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0xA59047B9
error: ERROR: Plug-in file does not match its digital signature. File may have been corrupted or altered. Error code: 2

Done.
-----------------------------------

Can you help me ?

Thanks

tanus74

Sanjay Kumar (sanjay-kumar14) said : #1

Hi,

Plugins for HPLIP are uploaded at http://www.openprinting.org website, which is unfortunately down due to an unexpected issue. Since the webserver is not available, installation of plugins is failing. We will get back to you once we make alternative arrangements for accessing the plugins.

Thanks,
Sanjay Kumar

Sanjay Kumar (sanjay-kumar14) said : #2

Hi,

Please find the plugin for HPLIP at http://hplipopensource.com/hplip-web/plugin_download.html
Steps for installing the plugin are also provided there. Sorry for the inconvenience caused.

Thanks,
Sanjay

Sanjay Kumar (sanjay-kumar14) said : #3

Marking it as "Solved" since fix is already provided.

gaetano iaquinta (iaq-gae) said : #4

Dear Sanjay Kumar

now printer works fine

thanks a lot

Gaetano Iaquinta

________________________________
From: Sanjay Kumar <email address hidden>
To: <email address hidden>
Sent: Thursday, September 22, 2011 8:01 AM
Subject: Re: [Question #171380]: HP device manager requires an additional driver plug-in...

Your question #171380 on HPLIP changed:
https://answers.launchpad.net/hplip/+question/171380

    Status: Answered => Solved

Sanjay Kumar changed the question status:
Marking it as "Solved" since fix is already provided.

--
You received this question notification because you asked the question.

hate_bugs_89 (oyv-soppelpost) said : #5

Jesus fucking Christ.

I tried this, according to hplipopensource.com .

At step 3, (Run the command su -c "sh hplip-3.11.7-plugin.run" to install the plug-in), it asks for a password which is not blank, and not my master password.

In the OR step, I select the .run file, but the programme won't let me press 'Next'.

:D

Stefano Ghidoni (ghidoni) said : #6

I experienced the same issue, and I guess it is because the plugin you are trying to install is not compatible with the hplip version you are using. You can check it by typing on a shell:

sudo sh hplip-3.11.7-plugin.run

which, in my case, leads to this message:

error: Plug-in version mismatch:
error: Plug-in version: 3.11.7
error: Installed HPLIP version: 3.10.6
error: Installed HPLIP version and plug-in version must match.

I solved by looking on google for the right version (hplip-3.10.6-plugin.run in my case) and downloading from a site which kept the file locally :)

Hope this helps!

cmltow (j-codding001) said : #7

None of these links to the driver work!!!

goutam kodu (goutam-hplip) said : #8

Hi cmlton,

Download the latest hplip-3.11.10 from http://hplipopensource.com/hplip-web/gethplip.html and install it by running command
"sh hplip-3.11.10.run"

Thanks,
Goutam Kodu

maurizio masotti3 (mm-masotti) said : #9

I have the same error as cmltow 2011-10-11:

sh hplip-3.11.10.run or hp-setup ERROR: plug-in file does not match its digital signature etc.
My printer is laserjet pro p1102,
 my system is Ubuntu 10.04 or suse 11.04 or debian.

Neiter http://www.openprinting.org
nor http://hplipopensource.com/hplip-web/plugin_download.html are active (both 404).

hplip-3.11.10 is downloaded from http://hplipopensource.com/hplip-web/gethplip.html

Confirming maurizio, same error on a recently installed ubuntu 10.10.

sh hplip-3.11.10.run or hp-setup

ERROR: plug-in file does not match its digital signature.

HP Laserjet P1005,

404 errors:
- http://www.openprinting.org
- http://hplipopensource.com/hplip-web/plugin_download.html

hplip-3.11.10 is downloaded from http://hplipopensource.com/hplip-web/gethplip.html

http://hplipopensource.com/hplip-web/plugin_download.html gets me a "Page Not Found" error as well, so there does not appear to be a source for the binaries.

Right now the link is working. I got the file.

Steps to install (from the link):

Steps to Install the plugin

-Download hplip-3.11.10-plugin.tar file from the above link
-Change to the downloaded directory and extract hplip-3.11.10-plugin.run file from tar file
-Run the command su -c "sh hplip-3.11.10-plugin.run" to install the plug-in
-Note: For this plugin to work please update your HPLIP to latest HPLIP-3.11.10. This plugin will not work with any other versions

If the link suddenly stops working, please download it from: http://www.rodrigow.com/hp/hplip-3.11.10-plugin.tar

Regards,

Same problem. My Ubuntu version is 12.04. None of above links are working. Screenshot (http://imgur.com/1KQQ3.png).

goutam kodu (goutam-hplip) said : #14

Can you please provide us the "hp-check -t" command output.
Please run command "sudo hp-plugin -i -g" to install the plugin and provide us its complete terminal output. Let us know if you are facing the issue still.

Rgds,
Goutam

Output of "hp-check -t" command is: http://pastebin.com/iLebL83q
And output of "sudo hp-plugin -i -g" command is: http://pastebin.com/98S3cE4t

@goutam: Thanks! That "sudo hp-plugin -i -g" command does the job! :)