hp e709n additional dry time

Asked by Vincenzo salvo on 2011-05-01

Hi I've got hp officejet 6500 e709n with hplip 3.10.6. I need to print double sided but it's not possible to change additional dry time: however I try to change "additional dry time" the printer will wait always the default time (15 seconds!)... I've tried hplip 3.11.3a but with this version there isn't the "additional dry time" option. Thank you so much in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Sanjay Kumar
Solved:
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Vincenzo salvo (venik88) said :
#2

Thanks for your useful answer...

Revision history for this message
Launchpad Janitor (janitor) said :
#3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Vincenzo salvo (venik88) said :
#4

lol

Revision history for this message
Sanjay Kumar (sanjay-kumar14) said :
#5

Hi,

Thanks for bringing it up. Unfortunately additional dry time is not supported in latest HPLIP release. Based on the priority we will try to take this up. Sorry for the inconvinience caused.

Thanks,
Sanjay

Revision history for this message
Vincenzo salvo (venik88) said :
#6

 Is there a roadmap for HPLIP ? It's an important feature and I hope it will be available as soon as possibile. Everytime i have to print several pages, I need a windows pc, any workaround??...
Thanks for your interest!

Revision history for this message
Best Sanjay Kumar (sanjay-kumar14) said :
#7

Hi,

For workaround please download hplip-3.11.5 tar file from http://hplipopensource.com/hplip-web/install/manual/index.html
and merge the following changes in the downloaded source.
___________________________________________________________
--- prnt/hpcups/Pcl3Gui2.cpp (revision 14871)
+++ prnt/hpcups/Pcl3Gui2.cpp (working copy)
@@ -137,6 +137,8 @@

     if (m_pJA->e_duplex_mode != DUPLEXMODE_NONE) {
         addToHeader((const BYTE *) EnableDuplex, sizeof(EnableDuplex));
+ addToHeader((const BYTE *) ExtraDryTime, sizeof(ExtraDryTime));
+ *cur_pcl_buffer_ptr++ = (BYTE) 0xF6; //0xF6 is 2's complement of -10. You can use any value from (-10 to -1) to reduce the dry time.
         speed_mech_enabled = false;
     }
______________________________________________________________

Then follow build and installation steps in the above link. Hope this helps.

Thanks,
Sanjay

Revision history for this message
Vincenzo salvo (venik88) said :
#8

I have changed Pcl3Gui2.cpp and I've installed hplip 3.11.5 but I can't understand if it works... now it seems wait like 7 seconds.... I can't understand how to change 0xF6 (I'm not a programmer)... Is 0xF6 the lowest value I can use??
In order to compile the program I've got change the script like this:

 if (m_pJA->e_duplex_mode != DUPLEXMODE_NONE) {
         addToHeader((const BYTE *) EnableDuplex, sizeof(EnableDuplex));
 addToHeader((const BYTE *) ExtraDryTime, sizeof(ExtraDryTime));
 *cur_pcl_buffer_ptr++ = (BYTE) 0xF6; //0xF6 is 2's complement of -10. You can use any value from (-10 to -1) to reduce the dry time.
         speed_mech_enabled = false;
     }

"+" gived to me some terminal errors

Thanks Sanjay for your precious help!!

Revision history for this message
Sanjay Kumar (sanjay-kumar14) said :
#9

Hi,

Total dry time = default dry time (15 seconds fixed) + additional dry time(currently 0). In order to reduce the total dry time please provide negative value of ExtraDryTime. e.g
Total dry time = 15 + (-10) = 5 secs

0xF6 is nothing but the hexadecimal representation of decimal minus 10. You can also provide the decimal values like -14, -13, -12,....,0, 10, .... etc

e.g
*cur_pcl_buffer_ptr++ = (BYTE) -14;
                         or
*cur_pcl_buffer_ptr++ = (BYTE) -12;
                        or
*cur_pcl_buffer_ptr++ = (BYTE) 5;

etc.......

Thanks,
Sanjay

Revision history for this message
Vincenzo salvo (venik88) said :
#10

Wonderful!!!!!! This definitely solved my problem!!!!!! Thank you for your time and consideration!!

    if (m_pJA->e_duplex_mode != DUPLEXMODE_NONE) {
         addToHeader((const BYTE *) EnableDuplex, sizeof(EnableDuplex));
addToHeader((const BYTE *) ExtraDryTime, sizeof(ExtraDryTime));
  *cur_pcl_buffer_ptr++ = (BYTE) -14;
         speed_mech_enabled = false;
     }

Revision history for this message
Vincenzo salvo (venik88) said :
#11

Thanks Sanjay Kumar, that solved my question.

Revision history for this message
Eduard B├╝rki (eizeila) said :
#12

10 years later:

My HP ENVY 5544 does only wait 2 seconds before pulling the paper in again in duplex mode.

So I have tried out this method from post #7.
With some help, I was successful in installing a patched HPLIP version of the original version 3.19.6 .

As waiting time I have taken this:
"*cur_pcl_buffer_ptr++ = (BYTE) 10;"
... which should add a waiting time of 10 seconds I guess.

But: Although in the printer settings tab "basic" has now additional setting lines, the behaviour of the printer is the same. It does not wait!

And no. My HP ENVY 5544 has no support for waiting time in the front display pannel.

What can I do?