Is it possible to share the c5280's scanner over the network?

Asked by Lee Hyde


I recently purchased a BT HomeHub v2.0A and decided to connect my HP PhotoSmart c5280 to its USB port to share the printer and (if possible scanner) over the network. I've been able to set up the printer using the printer configuration tool included in Ubuntu (system-config-printer) but for some reason neither hp-setup nor xsane are able to detect the printer or the scanner respectively.

I'd also clarify that I've tried all of the steps here ( but for some reason the command 'hp-makeuri' (the IP address of the routers USB port) does not detect any device (not a scanner; not even the printer which is currently operational in this configuration).

Is it at all possible to access this models scanner functionality via the network (under this network configuration)? If so, how does one go about setting this up?

FYI: I'm using the recommended HPIJS drivers and the printer is configured (via system-config-printer) and working via device URI lpd://

Any assistance would be greatly appreciated.

Kind Regards,

Lee Hyde.

Question information

English Edit question
HPLIP Edit question
No assignee Edit question
Solved by:
Lee Hyde
Last query:
Last reply:
Revision history for this message
Ani Balakrishnan (anib) said :


 Can you please try this command?
snmpwalk -Os -c public -v 1 <printer ip address>

The output should be similar to the following;
enterprises. = STRING: "MFG:Hewlett-Packard;CMD:PJL,MLC,BIDI-ECP,PCL,POSTSCRIPT,PCLXL;MDL:hp LaserJet 3380;CLS:PRINTER;DES:Hewlett-Packard LaserJet 3380;MEM:23MB;COMMENT:RES=1200x1;"

If it does not there may be an snmp problem on your system and/or network.

Thanks and Regards
Ani Balakrishnan

Revision history for this message
Lee Hyde (anubeon) said :

A late response I know, but I thought I'd but this out there for the world to read; the BT Home Hub 2.0A appears to have SNMP disabled by default so it looks like sharing my scanner over the network is out of the question (I assume). Such a shame that manufacturers and ISP opt to ship crippleware - the firmware in no way lives up to the potential of this hardware and I don't think any of the open xxxWRT projects have 'cracked' the BT Home Hub yet (neither v1.0, v2.0A/B or v3.0).