Log, instance and VNC Errors

Asked by Henrique Alho on 2013-04-18

Hey guys, I'm having problems... :(

-When I try to access to "containers" I got "Internal Server Error"

-When I create a new instance, the status stays "Error" task: None Power State: No state..

-When I go to details and click on "Log" I get: Unable to get log for instance "e5328a67-a2c3-4b5a-b5b5-9f4f1c5ea0f7".

Tried this:

virsh list --all
error: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory
error: failed to connect to the hypervisor

I followed the guide for Folsom from the openstack documentation...

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
Henrique Alho
Solved:
2013-04-30
Last query:
2013-04-30
Last reply:
2013-04-29

This question was reopened

Julie Pichon (jpichon) said : #1

Hi, there are probably configuration issues at play here.

- For the Containers panel, do you have Swift installed and running? Also, when reproducing the problem have a look at the apache logs to get a full stack trace and help with debugging the issue.

- For the new instance creation, I would look into the nova logs for more information.

- If the instance failed to get created at all, it won't have logs.

Henrique Alho (henriquev16) said : #3

Hi, thanks for your answer ! Finally I have some support!

- I don't have swift installed, I followed the Openstack Folsom Guide and there is no mention of Swift service to install

By the way, I'm having another problem here, when I try to restart the nova-compute service I get this error :

stop: unknown instance

Even if I try to do this again and again I always got this error

- Where can I find the logs? I'm sorry I'm a noob!

Julie Pichon (jpichon) said : #4

The new place for support questions is https://ask.openstack.org , you should try asking over there in the future :)

The Containers panel related to Swift (Object Storage), so if Swift isn't installed the panel won't work. Perhaps the tutorial told you to create the keystone endpoints for Swift but not how to install Swift. You should remove the endpoints for this service and the Container panel will disappear.

You can use:

$ keystone service-list
$ keystone endpoint-list

to figure out which endpoint belongs to swift and delete it.

If nova is somehow broken, this would explain why you can't start new instances. You should try to fix this first. The nova logs should be in /var/log/nova/ .

If you need the logs to understand a failure in the Horizon dashboard, you can look at the error logs in /var/log/apache2 (Ubuntu) or /var/log/httpd (Fedora). Hope this helps!

Henrique Alho (henriquev16) said : #5

I'm working with Putty to manage my physical machines and when I do : keystone endpoint-list I can't see all the output! Oh my god I have problem and problem and problem...

I already tried Ask.openstack but I haven't recivied help to solve my problems...

Henrique Alho (henriquev16) said : #6

I solved this problem by changing my compute machine by another .. the first does not support hypervisor ...

When I changed both machines, solve the problem was so simple like configure the new machine and start an instance

Julie Pichon (jpichon) said : #7

Great, good to know this is resolved!