Horizon:unable to retrieve quota information

Asked by yang on 2013-03-14

hi,all

i install the folsom version from the official website.when i finish the controller node, and look at the: http://localhost/horizon, there is something wrong, and to the top right corner,it shows: Error: Unable to retrieve quota information.
and the log in the nova-scheduler.log,nova-consoleauth.log,nova-cert.log shows:

2013-03-14 12:27:19 11519 ERROR nova.openstack.common.rpc.common [-] AMQP server on localhost:5672 is unreachable: Socket closed. Trying again in 1 seconds.
2013-03-14 12:27:20 11519 INFO nova.openstack.common.rpc.common [-] Reconnecting to AMQP server on localhost:5672
2013-03-14 12:27:23 11519 ERROR nova.openstack.common.rpc.common [-] AMQP server on localhost:5672 is unreachable: Socket closed. Trying again in 3 seconds.
2013-03-14 12:27:26 11519 INFO nova.openstack.common.rpc.common [-] Reconnecting to AMQP server on localhost:5672
2013-03-14 12:27:29 11519 ERROR nova.openstack.common.rpc.common [-] AMQP server on localhost:5672 is unreachable: Socket closed. Trying again in 5 seconds.

i think the rabbitmq-server has something wrong, i reinstall it and restart, but the problem still there...
someone can help me ?
thanks,
yang.

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
yang
Solved:
2013-03-14
Last query:
2013-03-14
Last reply:
Julie Pichon (jpichon) said : #1

You may have better luck asking this question to the nova folks for debugging help. The "Unable to retrieve quota information" message only indicates that Horizon didn't get an answer back from nova.

yang (yangchyeah) said : #2

i have solved my problem..
because my cinder.conf and nova.conf have something missing...

Thanos Tsitsipas (thantsi88) said : #3

Could you please share the solution for the problem? What was missing from the conf files?

Thanks

Hello Yang,

Could you please share the solution for the problem?
I am facing the same problem too and still trying to figure out the solution.

Thanks