Folsom on Ubuntu 12.04 -- Horizon did not show up

Asked by neo0 on 2012-10-06

I a trying to install Folsom on Ubuntu 12.04 following trunk documents of Openstack.
After I installed Horizon by this command:

# apt-get install -y memcached libapache2-mod-wsgi openstack-dashboard

I do not modify any values in /etc/openstack-dashboard/local_settings.py
then when I enter the IP of the node on browser, it only show up the Apache's default page.

What should I do next?
I am not familiar with django, so just wait for yours suggests.

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
neo0
Solved:
2012-10-07
Last query:
2012-10-07
Last reply:
neo0 (tungns-inf) said : #1

I've just checked the /etc/apache2/conf.d/openstack-dashboard.conf
It shows that the WSGIScriptAlias point to /horizon

WSGIScriptAlias /horizon /usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi

So I must use $IP/horizon to access dashboard.
The Openstack guide does not mention that :(

Sam Stoelinga (sammiestoel) said : #2

Also ran into this issue just now...

Also the static admin files seems not being loaded correctly, the interface is missing static files, but im not sure how to fix it yet. Anybody got a working wsgi config I could use as reference?

shake.chen (shake-chen) said : #3

I have same problem.

mingj (skyairmj) said : #4

Is it solved now?

Get the same problem as Sam did above...

neo0 (tungns-inf) said : #5

@Sam, Shake, Mingj: do you install Horizon on Ubuntu? Please do not install openstack-dashboard-ubuntu-theme.
This theme makes the interface crash in my case. So I remove it. Try to remove it and recheck:

$ sudo apt-get remove openstack-dashboard-ubuntu-theme

When you install horizon, just the command below to avoid install this theme.

$ sudo apt-get install --no-install-recommends openstack-dashboard