Cannot disable Quantum in Horizon

Asked by b4sher on 2012-10-05

For the moment, I am still using nova-network configured with VlanManager to manage the networking side of my openstack installation. I plan on moving to Quantum, but after further testing OVS. With that being said, following the documentation on "Configuring the Dashboard" for Folsom on Ubuntu 12.04, I have added "QUANTUM_DISABLE = False" to /etc/openstack-dashboard/local_settings.py but am still seeing errors in Horizon saying "Error: Unable to retrieve networks.". A look at the Apache logs shows that the Quantum client is failing to connect the Quantum service, which makes sense as there is no Quantum service. Because of this error, I cannot deploy instances from Horizon due to the requirement to specify a network, which is completely blank.

Should I be adding "QUANTUM_DISABLE = False" to an alternate config file?

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
Gabriel Hurley
Solved:
2012-10-05
Last query:
2012-10-05
Last reply:
2012-10-05

That documentation is completely 100% wrong. Can you post a link to the offending documentation?

Quantum integration (as with any service-dependent component in Horizon) is controlled by the presence of that service in your Keystone service catalog. So if you're still seeing Quantum-related issues then your Keystone is misconfigured.

b4sher (b4sherx) said : #2

Here is what I was referencing, maybe I misinterpretted it:

http://docs.openstack.org/trunk/openstack-compute/install/apt/content/configure-dashboard.html

After being advised from mnaser in the IRC to look at the source code, it seems that Quantum is pretty well integrated into Horizon, to the point that it cannot be excluded.

b4sher (b4sherx) said : #3

Thanks Gabriel Hurley, that solved my question.

Juan Pavlik (jjpavlik) said : #4

Hi guys, i reported this same problem in my grizzly deployment. The dashboard is not looking for the quantum-api server on keystone, is trying to connect staight to the host where the dashboard is. I found a workaround using redir to redirect the TCP connection, like this:

redir --debug --laddr=172.19.136.11 --lport=9696 --caddr=172.19.136.2 --cport=9696