Can not login Dashboard / Unable to find the server at mykeystoneurl.

Asked by neo0 on 2012-03-06

Hi all,

I installed Dashboard following this guide:
http://wiki.openstack.org/OpenStackDashboard

Everything fine, but when I run the server, I can not login with the username and password in DATABASE config in local_settings.py. Here's my config:

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'NAME': 'dashboarddb',
        'USER': 'nova',
        'PASSWORD': 'nova',
        'HOST': 'localhost',
        'default-character-set': 'utf8'
    },
}

When I run the Dashboard server and enter username + password. It returned this error on browser:
Unable to find the server at mykeystoneurl (HTTP 400)

And in the command line:

DEBUG:openstack_dashboard.settings:Running in debug mode without debug_toolbar.
DEBUG:openstack_dashboard.settings:Running in debug mode without debug_toolbar.
Validating models...

0 errors found
Django version 1.3.1, using settings 'openstack_dashboard.settings'
Development server is running at http://0.0.0.0:8888/
Quit the server with CONTROL-C.
Request returned failure status.
Traceback (most recent call last):
  File "/home/us/horizon/.venv/src/python-keystoneclient/keystoneclient/client.py", line 121, in request
    body = json.loads(body)
  File "/usr/lib/python2.7/json/__init__.py", line 326, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
[06/Mar/2012 15:20:03] "POST /auth/login/ HTTP/1.1" 200 3735

I also tried login as "admin" with password is "password" or "secrete" but I didn't work.
What's wrong?

Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
Tres Henry
Solved:
2012-05-18
Last query:
2012-05-18
Last reply:
2012-03-07
Best Tres Henry (tres) said : #1

Keystone is the auth backend for OpenStack services and Horizon. You need a functioning Keystone endpoint with a correctly configured service catalog and you need to update Horizon's local_settings.py file to point Horizon at it. The OPENSTACK_HOST setting in local_settings.py should be the IP address of your Keystone service. MySql is no longer needed to run Horizon.

It might help to check out DevStack (http://devstack.org/) and take a look at what it's doing to install OpenStack + Horizon.

neo0 (tungns-inf) said : #2

Thanks Tres Henry, that solved my question.

HuaHero (huahero-long) said : #3

The answer is very help.And I am very interesed how to see the command line infomation as the askers,please help,I am newer for openstack

neo0 (tungns-inf) said : #4

@HuaHero: just check in /etc/openstack-dashboard/