OpenStack Dashboard (Horizon)

vnc console isn't working

Asked by Rafael Durán Castañeda on 2011-04-12

I've got ~sleepsonthefloor/openstack-dashboard/vnc_console code in order to get VNC console option, however it isn't working. After clicking VNC console button a new tab is open but nothing is shown. In server output I can see HTTP connection neither fails nor succes:

Tue, 12 Apr 2011 14:13:57 GMT
/services/Cloud/services/Cloud/
DEBUG:boto:Method: GET
DEBUG:boto:Path: /services/Cloud/?AWSAccessKeyId=2cc070a6-7fdb-4fc1-9232-4ba64d53b5c3%3Amiproyecto&Action=GetVNCConsole&InstanceId=i-00000015&SignatureMethod=HmacSHA256&SignatureVersion=2&
 Timestamp=2011-04-12T14%3A13%3A57&Version=2009-11-30&Signature=nT75C0LuzpJFyias/6e6masUpKxzspAYuaUwk5gN2I8%3D
DEBUG:boto:Data:
DEBUG:boto:Headers: {'Date': 'Tue, 12 Apr 2011 14:13:57 GMT', 'Content-Length': '0', 'Authorization': u'AWS 2cc070a6-7fdb-4fc1-9232-4ba64d53b5c3:miproyecto:amMngnn7DQ6++k0dA9v8c+VMQ6Q=', 'User-Agent': 'Boto/1.9b (linux2)'}
DEBUG:boto:Host: None
DEBUG:boto:establishing HTTP connection

The server gets stuck there and stop working anymore.

Any suggestion?

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Dashboard (Horizon) Edit question
Assignee:
No assignee Edit question
Solved by:
Rafael Durán Castañeda
Solved:
2011-04-19
Last query:
2011-04-19
Last reply:

I solved it myself, nova-vncproxy wasn't running and dashboard keep waiting for its answer.

Hugo Kou (tonytkdk) said : #2

hello dude , there's no nova-vncproxy in my openstack nova.

how could I install nova-vncproxy?

I've got it from source code.

Devin Carlen (devcamcar) said : #4

nova-vncproxy was missing from the ubuntu packages. The packages have been fixed but for now you'll need to get nova-vncproxy from code in launchpad.