Is there a way to downgrade a data file (created with v5.3.1) so that it loads in v5.2.8?

Asked by Joe Forte on 2020-02-03

Recently upgraded to v5.3.1 but it has several changes (or bugs?) that I find very cumbersome. I'll open a support ticket for those. In the meantime, is there a way to modify my data file so it loads in v5.2.8 ? If I try loading it says the datafile was created with a different version and can't be loaded.

Question information

Language:
English Edit question
Status:
Answered
For:
HomeBank Edit question
Assignee:
No assignee Edit question
Last query:
2020-02-03
Last reply:
2020-02-07
Paul White (paulw2u) said : #1

I think the reason that Homebank data files are not backward compatible is to allow for new features changing the format. There is no supported way of downgrading the data file.

You could manually edit the version information in the file with a text editor but that is risky and unsupported. The format version of the file as changed recently so you might lose or corrupt your data.

For the last three years I've been making an extra backup of my data file at the end of each month. This means that I can always revert to a previous Homebank version if I need to. Even though I may have many items to re-input it's a much safer approach if I ever need to downgrade Homebank as I always have a version of the data file that matches the version of Homebank that I want to use.

Can you help with this problem?

Provide an answer of your own, or ask Joe Forte for more information if necessary.

To post a message you must log in.