Dark theme?

Asked by Tim Caldwell on 2019-07-18

Is is possible to support Windows 10 Dark theme with dark background and light text?
I am using Homebank version 5.2.6
Thank you
Tim

Question information

Language:
English Edit question
Status:
Solved
For:
HomeBank Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Caldwell
Solved:
2019-07-27
Last query:
2019-07-27
Last reply:
2019-07-27
Tim Caldwell (n1riw) said : #1

Is is possible to support Windows 10 Dark theme with dark background and light text?
I am using Homebank version 5.2.6
Thank you
Tim

Mistyk (skrzynkapanamarcina) said : #2

Please add dark theme Maxime, thank You :)

Kinnin Vo-Shay (vo-shay) said : #3

You can get Homebank to use a dark theme by adding 'gtk-application-prefer-dark-theme=1' to the settings.ini folder under the <Homebank install dir>/etc/gtk-3.0 folder.

It's not perfect, but it gets you 90% there.

Mistyk (skrzynkapanamarcina) said : #4

Kinnin Vo-Shay - nothing changed.

Mistyk (skrzynkapanamarcina) said : #5

But when I run gtk3-widget-factory, it's possible to include a dark theme and it looks great. But how do you turn it on in the application itself? Maxime help :)

Tim Caldwell (n1riw) said : #6

Can't modify that file says I dont have permission to to that even though I am the administrator of windows PC home use

Kinnin Vo-Shay (vo-shay) said : #7

@Mistyk - Don't know what to tell you. I add that line to the settings.ini file and save it, and the next time I open homebank it's dark (except for the top most bar). This is on Windows 10. I've pasted my ini file below for reference.

@Tim Caldwell - have you tried it with a user only install of Homebank? I then find it under C:\Users\<my username>\AppData\Local\Programs\HomeBank\etc\gtk-3.0

settings.ini
--------------------------------------------------------------------------
[Settings]
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintslight
gtk-xft-rgba=rgb

#gtk-alternative-button-order = false

#gtk-application-prefer-dark-theme = true
#gtk-dialogs-use-header = true

# FONT :: if you still run Windows XP comment below
gtk-font-name = Segoe UI 9
#gtk-font-name = Open Sans 14

# GTK+ THEME :: change GTK+ theme
gtk-application-prefer-dark-theme=1

# gtk-theme-name = Adwaita
# gtk-theme-name = Windows10

# GTK+ ICON THEME :: change icon theme
# gtk-icon-theme-name = Adwaita

Mistyk (skrzynkapanamarcina) said : #8

Hi it was my fault :)
Everything works great, I just didn't delete # in that line ;)

#gtk-application-prefer-dark-theme = true

Dark Theme looks awesome :)

Tim Caldwell (n1riw) said : #9

I keep getting I don't have permission to edit this file!

Kinnin Vo-Shay (vo-shay) said : #10

@Mistyk
Yes, the '#' character makes the line a comment, meaning the application will ignore it. That's why it can't be there.

@Tim Caldwell
What is the path of the settings.ini you're trying to edit?

Tim Caldwell (n1riw) said : #11

I tried file explorer and also tried editing in notepad...tried command prompt but there is no edit function in windows 10
Thanks

Maxime DOYEN (mdoyen) said : #12

Maxime DOYEN suggests this article as an answer to your question:
FAQ #2728: “Windows © : Change the theme used by GTK+”.

Tim Caldwell (n1riw) said : #13

The problem I edit in notepad to add that line and save but then I have to save the file in explorer and I keep getting that I do not have permission to save that file

Tim Caldwell (n1riw) said : #14

Finally figured in out...needed to kill read only on that folder...all set...thanks all
TC