Missing icons on Raspberry Pi Install

Asked by mick farris on 2019-03-24

Hi,
I have installed version 5.2.3 from source code using the ./configure, make and sudo make install commands and although the install seems to have worked I find that there are no icons displayed.
Using the same procedure to install version 5.1.8 worked fine.

Question information

Language:
English Edit question
Status:
Solved
For:
HomeBank Edit question
Assignee:
No assignee Edit question
Solved by:
mick farris
Solved:
2019-04-11
Last query:
2019-04-11
Last reply:
2019-04-10
Maxime DOYEN (mdoyen) said : #1

HomeBank also uses some native Adwaita icon theme, is it installed ?
try run from command lien to see if any message
use inspector to figure out missing icon and try to find them fin find command

mick farris (mpfarris) said : #2

Thanks for your help Maxine,

I have tried running from the command line and the message displayed is :-

(homebank:24356): Gtk-WARNING **: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.

I have no idea how to find & fix that !

Maxime DOYEN (mdoyen) said : #3

you did not answered my question: is adwaita & hicolor icon theme installed on your RPi ?

mick farris (mpfarris) said : #4

Hi, apologies for the delay, I have been in Spain. On checking both adwaita & hicolor are both installed :-

adwaita-icon-theme/stable,now 3.22.0-1+deb9u1 all [installed,automatic]
hicolor-icon-theme/stable,now 0.15-1 all [installed,automatic]

mick farris (mpfarris) said : #5

Hi Maxime,

I've closed this problem as I have just compiled your latest version 5.2.4 and all the icons are present !

Thanks for your great work.