How to change language?

Asked by ian_ep on 2009-01-29

I am an english native living in Denmark. My financial transactions are in DKK but I prefer to use Windows - and Homebank - with an english interface. My Homebank seems to have installed itself with the (unfinished) danish interface.

My question is then, how do I change the interface language of Homebank? I don't see any entry in preferences ...

Question information

Language:
English Edit question
Status:
Solved
For:
HomeBank Edit question
Assignee:
No assignee Edit question
Solved by:
Maxime DOYEN
Solved:
2009-02-05
Last query:
2009-02-05
Last reply:
2009-01-30
Best Maxime DOYEN (mdoyen) said : #1

There is no user preference for that. HomeBank normally adapt to the user language automatically.
I f you want to revert to english, then move to C:\Program Files\HomeBank\share\locale and remove the directory corresponding to Denmark.

ian_ep (iep) said : #2

Maxime,

> There is no user preference for that. HomeBank normally adapt to the user
> language automatically.
> I f you want to revert to english, then move to C:\Program
> Files\HomeBank\share\locale and remove the directory corresponding to
> Denmark.

Ah! OK, thank you.

Perhaps Homebank should ask when installing what language the user wants. Or
make it a preference.

Incedentally, my operating system is the English version, system locale is
UK English. Only keyboard and currency settings are set to Danish. I would
not say it is a safe assumption that I would want Danish language ...

Ian

ian_ep (iep) said : #3

Thanks Maxime Doyen, that solved my question.

samio (samfromlv) said : #4

I have similar problem:
My locale is Latvian (and i cannot change it because of other applications) but preferred language is Russian.

Steps to enable Russian:
1) Go to Program Files\HomeBank\share\locale\
2) Rename 'ru' folder to 'lv'
3) Start application!

The same thing for other languages.
Instead of 'ru' (Russian) use desired language and instead of 'lv' (Latvian) you current system locale (Control Panel -> Regional Settings -> Current format)

Hello,

I would like to know how I can do this on linux. I'm working on a debian-like linux (ubuntu) and my default locale is english. But I would like to have homebank in french. Where do I need to go to modify my locale? I saw homebank installed in /usr/local/share/homebank and a lot of locales installed in /usr/local/share/locale but I don't know how to make it select the good one.

Thanks in advance

Luciferion (mikolaj-q) said : #6

What about Linux solution? I'd like to use Homebank in polish but I like English as system language. What can i do to switch Homebank to polish? Anyone please?

Maxime DOYEN (mdoyen) said : #7

Please don't reopen solved question, this is a good way for anybody to reply.

For Linux, you can launch homebank the folowwing way to change language, but only from a console:

for example in fench : LANGUAGE='fr_FR:fr' ./src/homebank

or in russian: LANGUAGE='ru' ./src/homebank

Luciferion (mikolaj-q) said : #8

Thank You for answer.

Omar (ogonar) said : #9

It works for me. Thank you.

bobeshek (bobeshek) said : #10

Hello,
unfortunatelly the above doesn't work for me. I have Win 7, locale Czech. The preferred language is Czech as well but HomeBank is still in English only. I have even deleted all other directories in HomeBank\share\locale\ and only cs directory left.
Any suggestions?
Thanks.

Hi Maxime, thank you for the soft.

Is it possible to launch homebank under Ubuntu lucid with different language without a console?

Thanks!

I would like my homebank to be in german. It didn't automatically install german language. How can I change that? I allready downloaded a file homebank_homebank-de.po. How can import this? ... or something like that?
greetings

quadamage76 (matteo-erika) said : #13

I removed all languages except Italian, my PC is set on Italian language but, in any case homebank loads again english language. How can I solve it?

P.S.
My OS is win7 64bit

Seth007 (orhiannono) said : #14

For everyone on Win7 with problems on the languages, just delete all locals, except the folder of the language of choice. Then rename that folder to "en". Restart application --> Language should now be language of choice.

Btw, this is an excellent application, really love this!

AlBeBack (alain-russier) said : #15

Tips on Win7 works for me, thanks