What is "nan"?

Asked by Melvin Mitts on 2016-10-17

I downloaded HomeBank to check it out. After importing some data all the group /category screens display "nan" instead of the amount. If I click and open the individual transaction, it shows the correct amount. I tried searching for "nan" (no quotes) but found nothing. Can someone explain what "nan" is?
Thanks
Mel

Question information

Language:
English Edit question
Status:
Solved
For:
HomeBank Edit question
Assignee:
No assignee Edit question
Solved by:
Melvin Mitts
Solved:
2016-10-18
Last query:
2016-10-18
Last reply:
Melvin Mitts (melmitts) said : #1

Thanks for the response. For now I have moved on to another software program to check it out. I may come back and try HomeBank again later...

Maxime DOYEN (mdoyen) said : #2

"nan" means Not A Number
it may happens when homebank can't get a currency to render an amount.

I am interested on the behavior led you to get this display for sure !

Thx,
Max.

Melvin Mitts (melmitts) said : #3

Thanks for the reply. I figured it out after a while. I imported a
Quicken 2015 QIF file and even though it automatically created the
accounts it did not set the currency. I clicked on the Accounts menu and
selected 'Dollars' and then 'nan' went away.

Another problem that I have not been able to get to work on the imported
data. I have a Checking account and a Cash account. I withdraw cash from
the Checking account it shows as a debit however it does not register in
the Cash account. I tried using the 'Transfer' and 'Internal Transfer'
options. Neither work. For now I don't use the Cash account.

By the way, I downloaded the program when looking for a Quicken
replacement when I move to Linux in the near future. For now I am
running HomeBank on a Windows 10 Pro x64 computer.

Mel

On 2016-10-19 16:22, Maxime Doyen wrote:
> Your question #403107 on HomeBank changed:
> https://answers.launchpad.net/homebank/+question/403107
>
> Maxime Doyen posted a new comment:
> "nan" means Not A Number
> it may happens when homebank can't get a currency to render an amount.
>
> I am interested on the behavior led you to get this display for sure !
>
> Thx,
> Max.
>

ledom (sebastien-domeny) said : #4

Same bug here. The only solution is to create an account manually in € and then import operations into this new account, and not let homebank automaticaly create a new account.