hipl makefile install error

Asked by BaRom Kang on 2017-05-18

Hi, I am Korean Student wanting to use HIPL.

so I installed following steps

1. bzr checkout lp:hipl
2. apt-get install autoconf automake libtool make gcc libssl-dev iptables-dev \
                  libnet-ip-perl libnet-dns-perl bzr
3. apt-get install xmlto doxygen check libconfig8-dev miredo
4. apt-get install fakeroot dpkg-dev debhelper devscripts

5. build hipl --> this command autoreconf --install
                                                              ./configure && make in the installed hipl source tree ( /home/accl/hipl )

but fail to build hipl on this command : ./configure && make

my error is

libcore/builder.h:143:5: error: unused parameter ‘hip_build_param_hip_transform’ [-Werror=unused-parameter]
 int hip_build_param_hip_transform(struct hip_common *,
     ^
libcore/builder.c:1736:1: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute_ ’ before ‘{’ token
 {
 ^
libcore/linkedlist.h:61:16: error: unused parameter ‘free_elem_fn’ [-Werror=unused-parameter]
 typedef void (*free_elem_fn)(void *ptr);
                ^
In file included from libcore/state.h:42:0,
                 from libcore/builder.h:43,
                 from libcore/crypto.h:47,
                 from libcore/builder.c:99:
..

I think that linker does not recognize hipl source tree header.

How do I get to solve this problem??

i want to install successfully T.T

computer i'm using is
OS: ubuntu 4.4.0-75
gcc version : 5.4.0

Question information

Language:
English Edit question
Status:
Solved
For:
HIPL Edit question
Assignee:
No assignee Edit question
Solved by:
Miika Komu
Solved:
2017-06-02
Last query:
2017-06-02
Last reply:
2017-06-02
Miika Komu (miika-iki) said : #1

Juhani:

With a quick glance, it looks like your compiler is new enough that it issues warnings for unused parameters. The CFLAGS have a -Werror flag set, which tells make to treat all warnings as errors and stop the compile when encountered. Try adding -Wno-error=unused-parameter to CFLAGS and try again. I don't remember off the top of my head which configuration file has it, but a quick grep should help there.

Miika:

as a dirty hack, remove all -Wxx flags in configure.ac: AM_CFLAGS. I can take a look at this later.

BaRom Kang (barom123) said : #2

hello, thank you for your help

i did

./configure && make check

as result, my computer showed up this message.

=============================================================
Testsuite summary for HIP for Linux 1.0.8
=============================================================
# TOTAL: 0
# PASS: 0
# SKIP: 0
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 0

do i have succesful installation? if this case is right,

How to test unit test in HIPL?

BaRom Kang (barom123) said : #3

and how to real start in HIPL?? i wan to test two Locally-Connected Hosts.

after right install, automatically appear hipconf,hipd.. in /etc?

because i ran command line 'hipd'

but hipd is not working.

so i checked on the '/etc'

'/etc' inside did not exist 'hipd', 'hipconf'...

didn't i work to build hipl now?

Best Miika Komu (miika-iki) said : #4

About the unit tests, I think they're currently broken. I opened a new bug: https://bugs.launchpad.net/hipl/+bug/1695206

Anyway, I think you have built it correctly.

BaRom Kang (barom123) said : #5

Thanks Miika Komu, that solved my question.

Miika Komu (miika-iki) said : #6

About starting hipd. You have use sudo!

There are three ways the use HIPL:

1. By not installing it, directly from the command line sudo hipd/hipd -k (and correspondinly tools/hipconf)
2a. By installing it via "make install" and then invoking "sudo hipd -k"
2b. By installing it as a debian or redhat binary: "make bin" and then install the binary

(Please note that passing also -b flag will make hipd start as a background daemon)

In methods 1 and 2b. the hipd configuration will be located in /usr/local/etc. In method 2a, the configuration will be located in /etc

BaRom Kang (barom123) said : #7

WOW!!!!!!!!!!!! Thank you so much!!!!!!!!!!!! Thank u Thank u!!!!!!!