Haguichi says "error connecting"

Asked by Brandon on 2016-12-09

I am not very good with ubuntu, and can't figure out why it won't connect I've tried restarting the services with the command sudo service logmein-hamachi start && haguichi, I've tried uninstalling and reinstalling, and nothing. It worked at one point for like a day.

Question information

Language:
English Edit question
Status:
Solved
For:
Haguichi Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Brandt
Solved:
2016-12-17
Last query:
2016-12-17
Last reply:
2016-12-15
Stephen Brandt (ztefn) said : #1

Hi Brandon,

What is the output when you run "sudo service logmein-hamachi restart && sleep 2 && hamachi login"?

Brandon (darkvoltagebca) said : #2

So I actually decided to reset Ubuntu, I'm hoping that works. If it does not work still I will post back on here.

Brandon (darkvoltagebca) said : #3

So I reset Ubuntu, and nothing happened... I tried that command, and it just kinda sits there, nothing happens.

Stephen Brandt (ztefn) said : #4

How about starting the service using "sudo /etc/init.d/logmein-hamachi restart", does that result in any output?

Btw: What version of Ubuntu do you have?

Brandon (darkvoltagebca) said : #5

Here is the result "darkvoltagebca@Secondary:~$ sudo /etc/init.d/logmein-hamachi restart
[sudo] password for darkvoltagebca:
Restarting LogMeIn Hamachi VPN tunneling engine logmein-hamachihamachid: no process found

starting - success"

Brandon (darkvoltagebca) said : #6

Still no luck...

Brandon (darkvoltagebca) said : #7

16.04 LTS

Brandon (darkvoltagebca) said : #8

Here's one more thing, every time I press the power button in haguichi, a prompt pops up saying "Authentication is needed to run '/bin/systemctl' as the superuser" I type in my password, and it still says error connecting.

Stephen Brandt (ztefn) said : #9

It seemed like the restart using "sudo /etc/init.d/logmein-hamachi restart" was successful as it states "starting - success" at the end... The message is "hamachid: no process found" is just from stopping the old process, which isn't there as expected.

What's the output if you run the command "hamachi" after that restart?

Brandon (darkvoltagebca) said : #10

Here is the output "darkvoltagebca@Secondary:~$ sudo /etc/init.d/logmein-hamachi start
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachialready running

starting - success"

It still isn't working, unfortunately.

One more thing, every time I restart the computer and log in, a window pops up saying "Sorry, Ubuntu 16.04 has experienced an internal error." I click show details, and it says that the executable path is /opt/logmein-hamachi/bin/hamachid. It says that the problem type is a crash, and the there's a category labeled Title that says "hamachid crashed with SIGSEGV in_IO_vfscanf_internal()" Hopefully this helps in some way.

Stephen Brandt (ztefn) said : #11

Sorry, I meant the output for literally just the command "hamachi" after the service is started.

Or put in a single line: "sudo /etc/init.d/logmein-hamachi start && sleep 2 && hamachi"

The hamachi command should either output the client version, status, etc or report the reason why it cannot (no permission or deamon not running).

Stephen Brandt (ztefn) said : #12

Also, please make sure you have installed the latest Hamachi version (2.1.0.165 or 2.1.0.174) compatible with Ubuntu 16.04 installed. You can download the DEB package for the latest version from here: https://www.vpn.net/linux

Brandon (darkvoltagebca) said : #13

Here - "darkvoltagebca@Secondary:~$ sudo /etc/init.d/logmein-hamachi start && sleep 2 && hamachi
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachialready running

starting - success
Hamachi does not seem to be running.
Run '/etc/init.d/logmein-hamachi start' to start daemon."

Latest version (2.1.0.174) is installed.

Stephen Brandt (ztefn) said : #14

Thanks. Seems that the service was not started successfully or that the daemon had already crashed. You can try digging into the hamachi log file (/var/lib/logmein-hamachi/h2-engine.log) to see if there are any clues for the reason why.

Otherwise you can reinstall hamachi and hope that this will fix the problem (it does execute some extra triggers that might help):
sudo apt install --reinstall ~/Downloads/logmein-hamachi_2.1.0.174-1_amd64.deb

Brandon (darkvoltagebca) said : #15

No luck with reinstalling, here are lines from the log:
12.14 15:46:14.811 vpn: tap config done, [failed]
12.14 15:46:14.812 vpn: tap config failed, retry. [1]
12.14 15:46:14.812 dbg: disable(Hamachi), locked: 0
12.14 15:46:14.812 vpn: disabling [Hamachi] domain ..
12.14 15:46:14.823 vpn: domain [Hamachi] -> 'VPN_disabling'
12.14 15:46:14.823 vpn: on_set_tapdev(, 0) -> ok
12.14 15:46:14.823 vpn: domain [Hamachi] -> 'VPN_disabled'
12.14 15:46:14.823 dbg: setup_vpn_domain [Hamachi]
12.14 15:46:14.823 dbg: vpn_domain::config - [Hamachi]
12.14 15:46:14.823 dbg: enable(Hamachi), locked: 0
12.14 15:46:14.823 vpn: domain [Hamachi] -> 'VPN_opening'
12.14 15:46:14.823 vpn: enabling [Hamachi] domain ..
12.14 15:46:14.823 vpn: on_set_tapdev(, 1) -> ok
12.14 15:46:14.823 tap: device ham0 opened
12.14 15:46:14.823 vpn: domain [Hamachi] -> 'VPN_up'
12.14 15:46:14.824 dbg: setup_vpn_domain [Hamachi]
12.14 15:46:14.824 dbg: vpn_domain::config - [Hamachi]
12.14 15:46:14.824 vpn: domain [Hamachi] -> 'VPN_setting_up'
12.14 15:46:14.824 tap: config(ham0, 25.104.195.42, 255.0.0.0, [/96])
12.14 15:46:14.825 tap: ioctl(SIOCSIFADDR) IPv6 err, 13, Permission denied
12.14 15:46:14.825 tap: if_config() -> 0

Best Stephen Brandt (ztefn) said : #16

Googling for the errors in your log I found a forum post which describes the exact same problem. The solution seems to be to (re)enable IPv6 on your system:
http://www.linuxforums.org/forum/suse-linux/199805-logmein-hamachi-64-bit-cannot-start-daemon-post953782.html?s=66f888c449e4a522dc571194002c665e#post953782

Brandon (darkvoltagebca) said : #17

Sorry I wasn't able to respond to this earlier, but that solved my problem! Thanks!

Brandon (darkvoltagebca) said : #18

Thanks Stephen Brandt, that solved my question.

Stephen Brandt (ztefn) said : #19

Great it's solved. Out of curiosity, what was the reason you had disabled IPv6?

Brandon (darkvoltagebca) said : #20

I don't remember disabling IPv6, the only time I messed with network settings was when my network wasn't working, but I don't remember disabling it... Oh well, not a big deal now.

Thanks all i had the same problem and it was solved, Thanks Guys :-)