Haguichi thinks Hamachi not installed

Asked by Michael

Similar to another issue: https://answers.launchpad.net/haguichi/+question/169792, but not entirely I think.

I'm a Linux newbie so bear with me.

I can see my Linux box from other nodes on the Hamachi network, so am confident it's installed and running. Can ping both ways.

I am running Haguichi on Linux Mint 14 (Cinnamon), and running from the GUI tells me "Hamachi is not installed". I've copied the menu to desktop or panel for instance, same results. But when I run from command line, no sudo or anything, just haguichi, it runs fine and I see my networks nodes.

I'm wondering with all these GUI icons, it could be a symbolic link issue, some permission somewhere not set right?

This is really bizarre.

Question information

English Edit question
Haguichi Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Michael (mwpowellhtx) said :

Following up, I ran haguichi debug to see what would happen. It does seem a little slow to reconnect and join the network, but it's also running in a VM. Not sure why. It does eventually connect. Part of my confusion is knowing what to expect in a healthy working condition. Now Haguichi joins the network, whereas it wouldn't do that or would show Hamachi not installed when it is. How do I get Haguichi to start automatically, perhaps even as a service, unattended?

Revision history for this message
Michael (mwpowellhtx) said :

Here's a thought, and I don't know how doable this is being the Linux newbie that I am.

How possible would it be to automate the following command(s) so that it loads. Unattended would be great. If necessary in a user login script.

sudo service logmein-hamachi start && haguichi

That (re-)starts the Hamachi service and subsequently loads Haguichi, which then we have network again. Yay!

Through an admin script would be better, but the ones I have come across, or that appears to have installed with Hamachi, don't seem to work that well. Or I'm doing something wrong. Probably that.


Revision history for this message
Stephen Brandt (ztefn) said :

Hi Michael,

I have a Linux Mint 14 (Cinnamon) LiveCD running in VMware and after installing Hamachi + Haguichi I do not get the "Hamachi is not installed" message. All shortcuts in Cinnamon I tried seem to work fine (menu, desktop, panel).

If you want to start Haguichi automatically when you login to your desktop, you could normally check mark Haguichi in "Startup Application". But it seems Haguichi doesn't show up there anymore. You can fix this by copying the haguichi.desktop file from /usr/etc/xdg/autostart/ to one of these folders: /etc/xdg/autostart/ or ~/.config/autostart/
I will try to change to install path for that file in the next release.

Revision history for this message
Michael (mwpowellhtx) said :

Thanks I'll check that out. That's part 2 as far as Haguichi itself is concerned. Any idea why Hamachi wouldn't be starting as a service automatically? (Again, me = Linux Newbie). It seems like as long as I do that, I can run Haguichi.

Revision history for this message
Stephen Brandt (ztefn) said :

As far as I know the Hamachi daemon (service) is always started at boot. If the client was left logged on at shutdown, it will log on next startup. If the client was not logged on at shutdown, it will not log on next startup.

If you set Haguichi as startup application and select "Connect automatically", Haguichi will make sure Hamachi is started and logged on anyway.

Revision history for this message
Michael (mwpowellhtx) said :

I believe I see what it was. I was learning how to much around in the /etc/rc3.d directories and whacked the hamachi symbolic link. There are also probably dozens of hamachi admin scripts I've been sifting through to find one even half appropriate to my system. Got that down. Then relinked to my scripts, and avoid name confusion with "hamachi", so hamachi-admin, hamachi-start, S99hamachi-start, type thing. Now it works beautifully. Thanks!