Haguichi does not find or is able to start a network

Asked by Kristin on 2012-03-05

Hi folks

I installed Haguichi 1.0.14 on Ubuntu 11.10.
I can start the prog, but if I search the network friends and me are using, Haguichi turns up and up and up (ressources 100 %....) and nothing happens. Same while creating a new network.

DU you know what to do?

Maybe interesting: I am online via VPN (poor student :/). Maybe these two VPNs doen't like each other?
But in former windows-times that was not a problem.

Hope you can help, thanks
Kristin

Question information

Language:
English Edit question
Status:
Answered
For:
Haguichi Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-11
Last reply:
2012-03-18

This question was reopened

Stephen Brandt (ztefn) said : #1

Please start Haguichi from the terminal in debug mode by entering "haguichi --debug". When Haguichi is started, do whatever it is that isn't working. Then quit Haguichi, copy the output text from the terminal and send it to me by e-mail or paste it right here.

Maybe then i can see what's going on.

Kristin (schlabber) said : #2

Hi Stephen

Thanks for your advice.
I don't know why, today Haguichi works without any mistakes or errors ! Maybe after restart? (that's the only change I did since yesterday...)

No error in debug mode, do you still want to have the output?

Byebye
Kristin

Stephen Brandt (ztefn) said : #3

No output needed when everything works okay. But I would like to know what Hamachi version you have installed.

Kristin (schlabber) said : #4

Hi

My Haguichi Version is 1.0.14 on Ubuntu 11.10.

Unfortunately I cannot see the Starcraft game a friend is hosting using Hamachi 2.0 for Windows Vista. (...this is the correct version for Haguichi to communicate isn't it?)
As I was using Windows, too, it worked and we played toegether. Now it doesn't :(

Du you have an idea? He disabled his firewall and we're both in the same network...

Thanks!

Stephen Brandt (ztefn) said : #5

Hi Kirstin,

I meant the actual Hamachi version, which you can find in Client -> Information via the menubar. You most likely have either version 2.1.0.17 (Beta) or 0.9.9.9-20 (Legacy). All Haguichi does is controlling this installed Hamachi client. Hamachi does all the communication. Haguichi can't do anything without it.

About the Starcraft game or any communication over Hamachi in general:
1. Make sure you are both in the same network.
2. Make sure you are both online in this network (network should have a green icon in front).
3. Make sure both see each other as online (member should have a green icon in front of their name).
3. Check if you can ping each other.

If you cannot ping each other or have a bad connection:
a. Disable any firewall on pc and/or router on both sides.
b. Set any routers to port-forward the ports you are using over Hamachi.

Kristin (schlabber) said : #6

Hi

My client version is 2.1.0.17 as you said.

My friend (windows) is able to ping me. I cannot ping him (terminal opens with ping command but nothing happens - even no message that the aim is unreachable, just nothing happens).
He is green, I am green for him.

His firewall is disabled and I do not have one (ubuntu...). As we both played via Windows, he did'nt need to change settings in his router.

I am online via VPN in an student accomodation.
The firewall of my provider has this config (maybe useful):

For dynamic IPs this ports are open for input:

    FTP (Port 20/21 UDP/TCP)
    SSH (Port 22 TCP)
    HTTP (Port 80 TCP)
    IDENT (Port 113 TCP)
    HTTPS (Port 443 TCP)
    IPSec (Port 500 UDP, IP-Protokolle 50, 51)
    Ports 50000-50010 TCP
    Ports 50000-50010 UDP

Filter in- and output:

    ICMP Type 8 mit L├Ąge != 64 Bytes (84 Byte packet size)
    Port 80 TCP /default.ida Request (Code Red)
    Port 80 TCP /cmd.exe Request (MS IIS cmd.exe usage)
    Port 135 TCP/UDP (W32Blaster + Co)
    Port 139 TCP/UDP (CIFS)
    Port 445 TCP/UDP (W32Blaster + Co)
    Port 1434 UDP (SQL Slammer)
    Port 4444 TCP (W32Blaster)

There is a filter for static IPs for all TCP/UDP ports below 1024 in incoming direction (Stateful Inspection). Following services are allowed in incoming direction:

    FTP (Port 20/21 UDP/TCP)
    SSH (Port 22 TCP)
    SMTP (Port 25 TCP)
    HTTP (Port 80 TCP)
    IDENT (Port 113 TCP)
    HTTPS (Port 443 TCP)
    IPSec (Port 500 UDP, IP-Protokolle 50, 51)
    TCP Ports 1024-65535
    UDP Ports 1024-65535

Maybe the UDP - FIlter is problem, because we're supposed to play Starcraft via UDP because Windows Vista has no IPX anymore ;)
But afaik I don't have a static IP plus I found out that Starcraft is using TCP/UDP on port 6112.

So, any idea? :)
By the way thank you for your great support!

Kristin

Stephen Brandt (ztefn) said : #7

Hi Kristin,

Unfortunately, I don't have any idea. :(

Can you help with this problem?

Provide an answer of your own, or ask Kristin for more information if necessary.

To post a message you must log in.