how can i make progress from since I got a messege that 'Hamachi is not configured'

Asked by blogjh on 2011-09-01

I'm not a native speaker sorry

But my question is 'how can i make progress from since I got a message that 'Hamachi is not configured'

I use fedora 15, and I installed hamachi 2 from it(https://secure.logmein.com/labs/logmein-hamachi-2.1.0.17-1.i486.rpm) and I installed haguichi 1.0.11

and I got a message that shows Hamachi is not configured
if I click the Configure button, it doesn't even make any response

What can I do?

Question information

Language:
English Edit question
Status:
Answered
For:
Haguichi Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-01
Last reply:
2011-10-12
Stephen Brandt (ztefn) said : #1

To configure Hamachi and to (re)start the Hamachi deamon you need to provide root privileges. To gain these privileges Haguichi will launch a graphical su(do) command like gksu(do), gnomesu, kdesu(do) or beesu. Unfortunately Fedora has none of these installed by default. As beesu is the only available package in Fedora, I suggest you install this one.

Then, quit Haguichi and run this command in the terminal to make sure it will use beesu:
gconftool-2 --set "/apps/haguichi/commands/super_user" --type string "beesu"

Start Haguichi and try again.

Daniel Bentley (diskmaster) said : #2

I'm having this same issue with Fedora Core 15, Hamachi 2.1.0.17 and Haguishi 1.0.11

Hamachi is setup and working fine, all my computers through Hamachi can see and connect to my Fedora PC, but Haguichi thinks Hamachi isn't installed

beesu is already installed and it prompts (only the first time) for the root password, but it does nothing after that.

I tried gconftool-2 but it did nothing either, even with a reboot

Stephen Brandt (ztefn) said : #3

You are right. I recently found out that configuring doesn't work with beesu because it doesn't recognize the double dash used to mark the end of command options. I've contacted the author of beesu about this issue, but haven't received any reply (yet). I'll probably have to figure out some other syntax to use for beesu.

This is the current command to used by Haguichi to configure Hamachi:
{sudocommand} -- bash -c "echo 'Ipc.User {username}' >> /var/lib/logmein-hamachi/h2-engine-override.cfg; {scriptdirectory}/logmein-hamachi restart"

Feel welcome to suggest any syntax I could use for beesu. Please note that single and double quotes are already used for enclosure.

Stephen Brandt (ztefn) said : #4

Daniel, wait a moment, you are not having the same issue at all. Hamachi is setup and working on your Fedora machine, which means it's already installed and configured. Yet Haguichi thinks otherwise. Could you please start Haguichi from the terminal in debug mode (haguichi --debug) and send me the output? This should contain some clues why Haguichi thinks Hamachi isn't installed.

Stephen Brandt (ztefn) said : #5

Just a quick update. Configuring Hamachi through beesu will work in Haguichi 1.0.12 which will be released very soon.

Can you help with this problem?

Provide an answer of your own, or ask blogjh for more information if necessary.

To post a message you must log in.