dependency is not satisfiable: libmono-system2.0-cil

Asked by Michael on 2011-01-29

I am working on a Debian Lenny system. Debian GNU/Linux 5.0.8 Linux 2.6.26-686 (i686) GNU C Library version 2.7 (stable)
Hamachi is installed & functioning
I am attempting to install the haguichi_1.0.4_all.deb
I am getting the error: dependency is not satisfiable: libmono-system2.0-cil
I have check, and the file is present and up-to-date.
I have run commands # sudo synaptic and # sudo apt-get install -f and # sudo apt-get update
all is clear and up-to-date
Thank You

Question information

Language:
English Edit question
Status:
Solved
For:
Haguichi Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Brandt
Solved:
2011-01-29
Last query:
2011-01-29
Last reply:
2011-01-29
Stephen Brandt (ztefn) said : #1

Hi Michael,

Haguichi depends on version >= 2.4 of that package, while Debian Lenny seems to ship version 1.9.1:
http://packages.debian.org/lenny/libmono-system2.0-cil

Michael (mapalmer02) said : #2

Here is my Root Terminal session:
~# sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  udev xulrunner-1.9 xulrunner-1.9-gnome-support
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
~# sudo apt-get install libmono-system2.0-cil
Reading package lists... Done
Building dependency tree
Reading state information... Done
libmono-system2.0-cil is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
~# dpkg -i haguichi_1.0.4_all.deb
Selecting previously deselected package haguichi.
(Reading database ... 93933 files and directories currently installed.)
Unpacking haguichi (from haguichi_1.0.4_all.deb) ...
dpkg: haguichi: warning - conffile `etc/xdg' is not a plain file or symlink (= `/etc/xdg')
dpkg: haguichi: warning - conffile `etc/xdg/autostart' is not a plain file or symlink (= `/etc/xdg/autostart')
dpkg: dependency problems prevent configuration of haguichi:
 haguichi depends on libmono-system2.0-cil (>= 2.4); however:
  Version of libmono-system2.0-cil on system is 1.9.1+dfsg-6.
 haguichi depends on libmono-posix2.0-cil (>= 2.4); however:
  Package libmono-posix2.0-cil is not installed.
 haguichi depends on libgtk2.0-cil (>= 2.12.9); however:
  Version of libgtk2.0-cil on system is 2.12.1-2.
 haguichi depends on libglib2.0-cil (>= 2.12.9); however:
  Version of libglib2.0-cil on system is 2.12.1-2.
 haguichi depends on libgconf2.0-cil (>= 2.24.0); however:
  Version of libgconf2.0-cil on system is 2.20.1-1.
 haguichi depends on libnotify0.4-cil (>= 0.4.0~r2998); however:
  Package libnotify0.4-cil is not installed.
dpkg: error processing haguichi (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing: haguichi

Thank You.

Stephen Brandt (ztefn) said : #3

You are running a two year old distro which lacks the required packages. Now, what is your question?

Michael (mapalmer02) said : #4

Debian.org states "The last update to this release is 5.0.8 and was made on January 22nd, 2011"
My first question is: How is my distro now two years old when the operating system information I sent you matches the distro information provided by Debian and showing it as the newest?
Terminal session states "libmono-system2.0-cil is already the newest version." I understand this to mean as already installed and not in need of update.
My second question is: Why can't haguichi use the libmono-system2.0-cil that is already install on this machine?

Best Stephen Brandt (ztefn) said : #5

First question: It's only the "newest" version that Debian provides in their distro, which is actually pretty old. As Debian isn't a "rolling distro", the "updates" don't include newer version of concerned packages.

Second question: Because the version of the package is too old.

General advice: Use a more newbie friendly distro like Ubuntu, which provides an upgrade for the complete system every six months.

Michael (mapalmer02) said : #6

Thanks Stephen Brandt, that solved my question.