syntax for laconi.ca

Asked by Matt Rider on 2009-07-08

what are the syntax for laconica use...I can't figure it out

Question information

Language:
English Edit question
Status:
Solved
For:
Gwibber Edit question
Assignee:
No assignee Edit question
Solved by:
Ricardo Panaggio
Solved:
2009-07-30
Last query:
2009-07-30
Last reply:
2009-07-30
Jamal Fanaian (jamalta) said : #1

Thank you for request, but I wanted to ask for more information. Are you asking the syntax for messages? Such as how to reference a user, tag, or group? Please provide more information about what your question so that we can be of better assistance to you.

Matt Rider (theundecided) said : #2

what are the syntax for logging in to a laconica server.

information needed

username :

domain:

to sign in with twhirl you use <email address hidden> (ie <email address hidden>)

I havn't had succsess with this method or other methods
hope that helps

Jamal Fanaian (jamalta) said : #3

With Gwibber you don't use a specific syntax to specify a Laconica server. When you are creating an account (Accounts > Add) select Laconica as the service. Enter in your username and password, and for domain you enter in the domain of the Laconia service you are using. In your example, that would be army.twit.tv. You then select whether you want to receive messages and/or send messages to this account and save. Gwibber should then be able to interact with that account.

Matt Rider (theundecided) said : #4

I used

username: theundecided
password : <was correct but not going to say actualy>
domain: army.twit.tv

and I recieved

     Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/__init__.py", line 49, in get_data
    for message in method(client):
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/laconica.py", line 180, in responses
    for data in self.get_responses():
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/laconica.py", line 144, in get_responses
    "https://%s/api/statuses/replies.json" % self.account["domain"]))
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/laconica.py", line 125, in connect
    url, data, {"Authorization": self.get_auth()})).read()
  File "/usr/lib/python2.6/urllib2.py", line 124, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.6/urllib2.py", line 389, in open
    response = meth(req, response)
  File "/usr/lib/python2.6/urllib2.py", line 502, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.6/urllib2.py", line 427, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.6/urllib2.py", line 361, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 510, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 404: Not Found

Jamal Fanaian (jamalta) said : #5

It appears that army.twit.tv does not support SSL. Please try modifying the army.twit.tv account in Gwibber and checking the checkbox that is labeled "Allow insecure connection". This should resolve the error you are receiving.

Matt Rider (theundecided) said : #6

I don't see this option anywhere...please explane http://pikchur.com/DtR

Best Ricardo Panaggio (panaggio) said : #7

This option is available on newer versions of gwibber. I'm using 1.2.0 and it's available.

Matt Rider (theundecided) said : #8

Thanks Ricardo Panaggio, that solved my question.