Get more tweets when starting

Asked by Andreas Streim on 2009-01-09

I'd like a setting to tell Gwibber, how many tweets / feeds whatever it should retrieve when started. Maybe it is even possible that Gwibber remebers the last tweet it received before closing last time and tries to get all tweets since this time.

For me that would be a very useful feature.

Question information

Language:
English Edit question
Status:
Solved
For:
Gwibber Edit question
Assignee:
No assignee Edit question
Solved by:
Andreas Streim
Solved:
2009-01-18
Last query:
2009-01-18
Last reply:
2009-01-11
Sean Carlos (sean-antezeta) said : #1

Ryan told me this:

there is a trick you can use now to boost the number of messages that Gwibber displays for specific services. There isn't an option for it in the UI yet, but you can manually set it through gconf. Use gconf-editor to navigate to the /apps/gwibber/accounts directory and then find the accounts subdirectory for twitter. Create a new key called receive_count and set it to whatever value you want. The default is 20, but I think the maximum is 200. This will work for both Twitter and Identi.ca, but you have to set the value for each account individually. Keep in mind that Gwibber will pull that many messages down in every refresh, so it will increase memory consumption and slow down refreshes if you set it too high.

Thanks, I will have a look.

Maybe it would be possible to a) add this tu the UI and b) have a seperate setting for the number of messages to pull *when startet*.

So it would be possible for example to get 200 messages when started the first time, but then stick to 20 for the time it is running (what is enough, as I think).

Even better would be if Gwibber saves the time of the last message it had received before shutting down and then collects the number of messages set for the first start as a maximum - or stops when it arrives at a message, it has already shown the last time used.

Okay, as a workaround I made a script to start gwibber looking like:

gconftool-2 --set "/apps/gwibber/accounts/1t1222.../receive_count" --type int 100
gwibber&
sleep 10
gconftool-2 --set "/apps/gwibber/accounts/1t1222.../receive_count" --type int 20

"1t1222..." is the name of the accounts subdirectory of my twitter account.

The script sets the number of tweets to receive to 100, starts gwibber and waits a moment for gwibber to load and read the gconfig-file. Then ist sets the value back to 20 for the rest of the time running - and exits.

see related bug 311793 and its attached branch for the right way of achieving this

Justin Mason (jm-jmason) said : #5

It'd be great if this could be fixed. hopefully bug 311793 does the trick...

Laurent Dinclaux (dreadlox) said : #6

I still don't get why Gwibber isn't loading my tweets as I scroll down like every other desktop/web/mobile twitter apps....