erlang ssl_esock - upload bandwidth nearly 100%, why?

Asked by Savvas Radevic on 2010-04-15

I start gwibber and it maxes out my network upload, around 11-14KB/s (max upload is about 16KB/s). It seriously slows down my networking. I have to kill a process "ssl_esock" to get it back to normal.

I have noticed that it's sending something to Canonical servers (couchdb one ubuntu com).

1. What is being sent?
2. Why does it choke my upload?
3. How do I stop it from being sent?
4. How do I stop it using up my bandwidth?

Process number in question is 4100, according to "sudo nethogs eth1":

$ ps aux | grep erlang
forger 3913 0.1 0.7 109872 14612 ? Sl 07:42 0:00 /usr/lib/erlang/erts-5.7.4/bin/beam.smp -Bd -K true -- -root /usr/lib/erlang -progname erl -- -home /home/forger -- -noshell -noinput -smp auto -sasl errlog_type error -pa /usr/lib/couchdb/erlang/lib/couch-0.10.0/ebin /usr/lib/couchdb/erlang/lib/mochiweb-r97/ebin /usr/lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin /usr/lib/couchdb/erlang/lib/erlang-oauth/ebin -eval application:load(ibrowse) -eval application:load(oauth) -eval application:load(crypto) -eval application:load(couch) -eval crypto:start() -eval ssl:start() -eval ibrowse:start() -eval couch_server:start([ "/etc/couchdb/default.ini", "/etc/xdg/desktop-couch/compulsory-auth.ini", "/home/forger/.config/desktop-couch/desktop-couchdb.ini"]), receive done -> done end. -pidfile /home/forger/.cache/desktop-couch/desktop-couchdb.pid -heart
forger 4023 4.7 1.7 140504 36176 ? Sl 07:42 0:07 /usr/lib/erlang/erts-5.7.4/bin/beam.smp -Bd -K true -- -root /usr/lib/erlang -progname erl -- -home /home/forger -- -noshell -noinput -smp auto -sasl errlog_type error -pa /usr/lib/couchdb/erlang/lib/couch-0.10.0/ebin /usr/lib/couchdb/erlang/lib/mochiweb-r97/ebin /usr/lib/couchdb/erlang/lib/ibrowse-1.5.2/ebin /usr/lib/couchdb/erlang/lib/erlang-oauth/ebin -eval application:load(ibrowse) -eval application:load(oauth) -eval application:load(crypto) -eval application:load(couch) -eval crypto:start() -eval ssl:start() -eval ibrowse:start() -eval couch_server:start([ "/etc/couchdb/default.ini", "/etc/xdg/desktop-couch/compulsory-auth.ini", "/home/forger/.config/desktop-couch/desktop-couchdb.ini"]), receive done -> done end. -pidfile /home/forger/.cache/desktop-couch/desktop-couchdb.pid -heart
forger 4100 0.2 0.1 19728 2896 ? Ss 07:42 0:00 /usr/lib/erlang/lib/ssl-3.10.7/priv/bin/ssl_esock
forger 4161 0.0 0.0 7620 920 pts/1 S+ 07:45 0:00 grep erlang

$ netstat -pn | grep "3913\|4023\|4100"
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp 0 0 127.0.0.1:49546 127.0.0.1:49017 ESTABLISHED 4023/beam.smp
tcp 72204 0 127.0.0.1:60857 127.0.0.1:41366 ESTABLISHED 4100/ssl_esock
tcp 69642 0 127.0.0.1:60857 127.0.0.1:48903 ESTABLISHED 4100/ssl_esock
tcp 0 16656 192.168.1.2:45479 91.189.89.213:443 ESTABLISHED 4100/ssl_esock
tcp 0 151808 127.0.0.1:59991 127.0.0.1:60857 ESTABLISHED 4023/beam.smp
tcp 0 136960 127.0.0.1:54159 127.0.0.1:60857 ESTABLISHED 4023/beam.smp
tcp 0 12492 192.168.1.2:47370 91.189.89.212:443 ESTABLISHED 4100/ssl_esock
tcp 0 118 192.168.1.2:37210 91.189.89.212:443 ESTABLISHED 4100/ssl_esock
tcp 0 29148 192.168.1.2:49236 91.189.89.213:443 ESTABLISHED 4100/ssl_esock
tcp 61710 0 127.0.0.1:60857 127.0.0.1:59991 ESTABLISHED 4100/ssl_esock
tcp 76032 0 127.0.0.1:60857 127.0.0.1:51467 ESTABLISHED 4100/ssl_esock
tcp 0 24984 192.168.1.2:47637 91.189.89.213:443 ESTABLISHED 4100/ssl_esock
tcp 76032 0 127.0.0.1:60857 127.0.0.1:54159 ESTABLISHED 4100/ssl_esock
tcp 0 160256 127.0.0.1:48903 127.0.0.1:60857 ESTABLISHED 4023/beam.smp
tcp 0 12492 192.168.1.2:43494 91.189.89.212:443 ESTABLISHED 4100/ssl_esock
tcp 76032 0 127.0.0.1:60857 127.0.0.1:53653 ESTABLISHED 4100/ssl_esock
tcp 0 206848 127.0.0.1:41366 127.0.0.1:60857 ESTABLISHED 4023/beam.smp
tcp 57900 0 127.0.0.1:60857 127.0.0.1:51740 CLOSE_WAIT 4100/ssl_esock
tcp 0 22208 192.168.1.2:50421 91.189.89.213:443 ESTABLISHED 4100/ssl_esock
tcp 0 13880 192.168.1.2:35776 91.189.89.213:443 ESTABLISHED 4100/ssl_esock
tcp 0 202496 127.0.0.1:51467 127.0.0.1:60857 ESTABLISHED 4023/beam.smp

$ dig +noall +answer -x 91.189.89.213; dig +noall +answer -x 91.189.89.212
213.89.189.91.in-addr.arpa. 3527 IN PTR couchdb-one-ubuntu-com.amatungulu.canonical.com.
212.89.189.91.in-addr.arpa. 3542 IN PTR couchdb-one-ubuntu-com.calamansi.canonical.com.

Question information

Language:
English Edit question
Status:
Solved
For:
Gwibber Edit question
Assignee:
No assignee Edit question
Solved by:
Savvas Radevic
Solved:
2010-04-15
Last query:
2010-04-15
Last reply:
Savvas Radevic (medigeek) said : #1

I disabled everything in System -> Preferences -> Ubuntu one -> Services and restarted it