run gufw automatically without entering password at startup

Asked by D. Hoff on 2010-01-25

How can I be sure ufw is actually running on my system? I put gufw in my Startup Applications and when I start a new session gufw sometimes reports that the firewall is NOT enabled so I check the Enable box and close gufw. Also, I can't seem to find a way to have gufw start without first entering my password (root / administrator?)

Thanks for the help. I am very new to Ubuntu / Linux. -Doug

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2010-01-26
Last query:
2010-01-26
Last reply:
2010-01-26
Best costales (costales) said : #1

Hi!
Please, see this answer ;)
https://answers.launchpad.net/gui-ufw/+faq/184

D. Hoff (douglas-hoff) said : #2

Thanks! That makes sense. Ubuntu and its friendly & helpful support staff makes computing fun again!

Sage5 (tam954) said : #3

Why is it when I run Ubuntu the Gufw Firewall doesn't appear to be active. I always have to click the "unlock" button and enter my password. When I close Gufw and restart it I have to do the "unlock" and password each time. Is this normal if so why? If Gufw is still active even though it appears NOT TO BE ACTIVE, why isn't there some sort of indication that it's still offering protection?

Thanks for any info you may provide..

costales (costales) said : #4

@Sage5: Yes, it's normal ;) It's a security feature, only an admin user can run Gufw and 'see' the rules ;)
Until you enter the password, you can't see any rule or the state of firewall ;)
Best regards!